ACM: 广搜+素数  poj 3126 (素数表…

                                                                  Prime Path

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.

1033
1733
3733
3739
3779
8779
8179

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3

1033 8179

1373 8017

1033 1033

Sample Output

6

7

0

 

题意: 内阁大臣要改办公室门牌. 大臣是素数爱好者.门牌每次更改只可以更改一个数字.

         现在给定一开始的门牌号,和最后的门牌号. 计算出最少的更改次数就可以成功.

解题思路:

                 1. 还是BFS(广搜) , 这题目做烂了.

                 2. 素数判定, 采用打表解决.

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
#define MAX 100005
int dir[5] = {1,10,100,1000,10000};

struct node
{
    int num;
    int dist;
};

bool prime[MAX*10];
bool visit[MAX*10];
node start , end;

void init()
{
    memset(prime,false,sizeof(prime));
    int i,j;
    for(i=2;i<10000;i++)
        for(j=i;i*j<10000;j++)
            prime[i*j]=true;
}

int bfs(node start)
{
    queue<node> qu;
    node t;
    int result = 0;
    
    qu.push(start);
    
    while( !qu.empty() )
    {
        t = qu.front();
        qu.pop();
        
        if(t.num == end.num)
        {
            result = t.dist;
            break;
        }
        
        for(int i = 0; i < 4; ++i)
        {
            node tt;
            for(int j = 0; j < 10; ++j)
            {
                int num1 = j * dir[i];
                int num2 = t.num % dir[i+1];
                int num3 = t.num % dir[i];
                tt.num = t.num - num2 + num1 + num3;
                tt.dist = t.dist + 1;
                if(tt.num >= 1000 && tt.num <= 10000 && !prime[tt.num] && !visit[tt.num])
                {
                    visit[tt.num] = true;
                    qu.push(tt);
                }
            }
        }
    }
    
    return result;
}


int main()
{
//    freopen("input.txt","r",stdin);
    int n;
    init();
    scanf("%d",&n);
    while(n--)
    {
        int result = 0;
        memset(visit,false,sizeof(visit));
        scanf("%d %d",&start.num,&end.num);
        start.dist = 0;

        result = bfs(start);
        if(start.num == end.num)
            printf("0\n");
        else if(result == 0)
            printf("Impossible\n");
        else
            printf("%d\n",result);
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值