ACM: 深搜+剪枝 poj 1416

                                                           Shredding Company

Description

You have just been put in charge of developing a new shredder for the Shredding Company Although a "normal" shredder would just shred sheets of paper into little pieces so that the contents would become unreadable, this new shredder needs to have the following unusual basic characteristics.

1.The shredder takes as input a target number and a sheet of paper with a number written on it.

2.It shreds (or cuts) the sheet into pieces each of which has one or more digits on it.

3.The sum of the numbers written on each piece is the closest possible number to the target number, without going over it.

For example, suppose that the target number is 50, and the sheet of paper has the number 12346. The shredder would cut the sheet into four pieces, where one piece has 1, another has 2, the third has 34, and the fourth has 6. This is because their sum 43 (= 1 + 2 + 34 + 6) is closest to the target number 50 of all possible combinations without going over 50. For example, a combination where the pieces are 1, 23, 4, and 6 is not valid, because the sum of this combination 34 (= 1 + 23 + 4 + 6) is less than the above combination's 43. The combination of 12, 34, and 6 is not valid either, because the sum 52 (= 12 + 34 + 6) is greater than the target number of 50.

ACM: <wbr>深搜+剪枝 <wbr>poj <wbr>1416
Figure 1. Shredding a sheet of paper having the number 12346 when the target number is 50



There are also three special rules :

1.If the target number is the same as the number on the sheet of paper, then the paper is not cut.

For example, if the target number is 100 and the number on the sheet of paper is also 100, then

the paper is not cut.

2.If it is not possible to make any combination whose sum is less than or equal to the target number, then error is printed on a display. For example, if the target number is 1 and the number on the sheet of paper is 123, it is not possible to make any valid combination, as the combination with the smallest possible sum is 1, 2, 3. The sum for this combination is 6, which is greater than the target number, and thus error is printed.

3.If there is more than one possible combination where the sum is closest to the target number without going over it, then rejected is printed on a display. For example, if the target number is 15, and the number on the sheet of paper is 111, then there are two possible combinations with the highest possible sum of 12: (a) 1 and 11 and (b) 11 and 1; thus rejected is printed. In order to develop such a shredder, you have decided to first make a simple program that would simulate the above characteristics and rules. Given two numbers, where the first is the target number and the second is the number on the sheet of paper to be shredded, you need to figure out how the shredder should "cut up" the second number.

Input

The input consists of several test cases, each on one line, as follows :

tl num1
t2 num2
...
tn numn
0 0

Each test case consists of the following two positive integers, which are separated by one space : (1) the first integer (ti above) is the target number, (2) the second integer (numi above) is the number that is on the paper to be shredded.

Neither integers may have a 0 as the first digit, e.g., 123 is allowed but 0123 is not. You may assume that both integers are at most 6 digits in length. A line consisting of two zeros signals the end of the input.

Output

For each test case in the input, the corresponding output takes one of the following three types :

sum part1 part2 ...
rejected
error

In the first type, partj and sum have the following meaning :

1.Each partj is a number on one piece of shredded paper. The order of partj corresponds to the order of the original digits on the sheet of paper.

2.sum is the sum of the numbers after being shredded, i.e., sum = part1 + part2 +...

Each number should be separated by one space.
The message error is printed if it is not possible to make any combination, and rejected if there is
more than one possible combination.
No extra characters including spaces are allowed at the beginning of each line, nor at the end of each line.

Sample Input

50 12346

376 144139

927438 927438

18 3312

9 3142

25 1299

111 33333

103 862150

6 1104

0 0

Sample Output

43 1 2 34 6

283 144 139

927438 927438

18 3 3 12

error

21 1 2 9 9

rejected

103 86 2 15 0

rejected

 

题意: 给你两个数字, 第一个是最大值,第二个数字是用来拆分相加的,拆分只可以相邻的数字组合要尽可能大,

         但是不可以超过最大值, 当任意拆分组合成的值都大于最大值,输出error, 当尽可能最大的值不只一个组合

         输出rejected, 否则输出尽可能的最大值和组合的情况.

解题思路:

               1. 规模最大的序列不超过6位数. 规模不大.

               2. 明显是深搜的题. 就用解答树的思想吧. (解答树相信参加ACM的人都知道)

               3. 递归的参数cur: 当前尽可能大的值, reLen: 已经使用的长度(最大是序列长度 <=6)

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

int t,num;
int vis[6];
int ans[6];
int result[6];
int k;
int sum;
int flag;

void dfs(int cur,int reLen)
{
    if(cur > t)
        return ;
    if(reLen == k)
    {
        if(cur > sum)
        {
            flag = 0;
            sum = cur;
            memcpy(result,vis,sizeof(result));
        }
        else if(cur == sum)
            flag++;
    }
    
    for(int i = reLen; i < k; ++i)
    {
        for(int j = 1; j <= vis[i-1]*10; j += vis[i-1]*10-1)
        {
            vis[i] = j;
            dfs(cur+ans[i]*j,i+1);
            vis[i] = 0;
        }
    }
}

int main()
{
//    freopen("input.txt","r",stdin);
    while(scanf("%d %d",&t,&num) != EOF)
    {
        if(t == 0 && num == 0)
            break;
        
        k = 0;
        sum = 0;
        int tt = num;
        while(tt > 0)
        {
            ans[k++] = tt % 10;
            sum += ans[k-1];
            tt /= 10;
               
        if(sum > t)
        {
            printf("error\n");
            continue;
        }
        
        memset(result,0,sizeof(result));
        sum = 0;
        vis[0] = 1;
        flag = 0;
        dfs(ans[0],1);
        
        if(flag > 0)
            printf("rejected\n");
        else
        {
            printf("%d ",sum);
            for(int i = k-1; i >= 0; --i)
            {
                printf("%d",ans[i]);
                if(result[i] == 1)
                    printf(" ");                
            }
            printf("\n");
        }
        
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值