ACM: 深搜 poj 2531  (一开始,居然…

                                                                      Network Saboteur

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer -- the maximum traffic between the subnetworks.

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3

0 50 30

50 0 40

30 40 0

Sample Output

90

 

题意: 坏学生要破坏学校网络. 要找出两个A~B两个子网络的最大距离.

 

解题思路:

                  1.一开始却已为直接kruskal改一改最大生成树. 水之. (WA了一次.)

                  2.看了讨论,发现题意不是这回事.(T.T).

                  3. 还是深搜那回事.

          解析:

                 (1). 深搜入口. 枚举节点node, 将所有的节点先归入第一个子网络.

                 (2). 递归过程就是寻找最合适的分配节点的过程,这个就是深搜的思想.

                 (3). 讨论上还有许许多多的剪枝方法.(有待我细看学习).

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 21

int grid[MAX][MAX];
int result;
int div[MAX];   //分成两个集合: 0 , 1 (初始化为0).
int n;

void dfs(int node,int data)
{
    int cur = data;
    div[node] = 1;
    for(int i = 0; i < n; ++i)     //记录当前的“最大”连通和.
    {
        if(div[i] == 0)
            cur += grid[i][node];
        else
            cur -= grid[i][node];
    }
    
    if(cur > result)
        result = cur;
        
    for(int i = node+1; i < n; ++i)  //递归寻找合适的节点分配.
    {
        if(cur > data)
        {
            dfs(i,cur);
            div[i] = 0;
        }
    }
}

int main()
{
    freopen("input.txt","r",stdin);
    while(scanf("%d",&n) != EOF)
    {
        for(int i = 0; i < n; ++i)
        {
            for(int j = 0; j < n; ++j)
            {
                scanf("%d",&grid[i][j]);
            }
        }
        
        result = 0;
        memset(div,0,sizeof(div));
        dfs(0,0);
        
        printf("%d\n",result);
    }
    
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值