ACM: dp题 poj 1276  go on 动态规…

                                                                      Cash Machine

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3 4 125 6 5 3 350

633 4 500 30 6 100 1 5 0 1

735 0

0 3 10 100 10 50 10 10

Sample Output

735

630

0

0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

 

题意: 现在给你一个询问值. 要求你在N种值中寻找尽量能凑出询问值.如果不行请计算最接近的值.

         N种值的每一种的个数会给出.

 

解题思路:

                1.动态规划题--> 背包问题. 状态标记就可以了.

                2. d[i] 表示是否达到i值.

                3. 规划的起点是d[0]; 当满足当前 j+d[i]*k > s 就dp[ j+d[i]*k  ]标记.

                    j是当前枚举的“询问值” (0<= j <= s );    d[i]是第i种值. k是d[i]个数 (1<=k<= n[i])

                    n[i]是第i种值的总个数.

                4. 从dp[s] 开始往下搜索.

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 100005

int s, N;
int n[10], d[10];
bool dp[MAX];

int main()
{
//    freopen("input.txt","r",stdin);
    while(scanf("%d %d",&s,&N) != EOF)
    {
        for(int i = 1; i <= N; ++i)
        {
            scanf("%d %d",&n[i],&d[i]);
        }
        
        memset(dp,false,sizeof(dp));
        dp[0] = true;
        
        for(int i = 1; i <= N; ++i)
        {
            for(int j = s; j >= 0; --j)
            {
                if(dp[j])
                {
                    for(int k = 1; k <= n[i]; ++k)
                    {
                        if( (j+d[i]*k) > s)
                            break;
                        dp[j+d[i]*k] = true;
                    }
                }
            }
        }
        
        for(int i = s; i >= 0; --i)
        {
            if(dp[i])
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值