ACM: 条件最短路 poj 1724 (没剪枝…

                                                                   ROADS

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :

  • S is the source city, 1 <= S <= N
  • D is the destination city, 1 <= D <= N
  • L is the road length, 1 <= L <= 100
  • T is the toll (expressed in the number of coins), 0 <= T <=100


Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.

Sample Input

5

6

7

1 2 2 3

2 4 3 3

3 4 2 4

1 3 4 1

4 6 2 1

3 5 2 0

5 4 3 2

Sample Output

11

 

题意: 现在要从1 到达 n城市, 每个城市之间的链接都知道, 道路的长度和费用.

         求在小于等于费用K下最短路径.

解题思路:

                1. 条件最短路. 依然是记忆化深搜 + 剪枝.

                2. 可恨的测试数据有N多个环. TLE多次.

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 1005
const int INF = 1 << 30;

struct node
{
    int v;
    int len;
    int cost;
    int next;
}edges[MAX*10];

int K;
int n, m;
int next[MAX*10];
int vis[MAX];
int num;
int result;

void init()
{
    num = 0;
    result = INF;
    memset(next,-1,sizeof(next));
    memset(vis,0,sizeof(vis));
}

void dfs(int v,int w,int cost)
{
    if(w > INF)
        return ;
    if(v == n)
    {
        if(result > w)
            result = w;
        return ;
    }
    
    for(int e = next[v]; e != -1; e = edges[e].next)
    {
        int len = edges[e].len;
        int t_cost = edges[e].cost;
        if( vis[ edges[e].v ] <= 1)
        {
            vis[ edges[e].v ]++;
            if(t_cost + cost <= K && w+len < result)
                dfs(edges[e].v,w+len,t_cost+cost);
            vis[ edges[e].v ]--;
        }
    }
}

int main()
{
//    freopen("input.txt","r",stdin);
    int u, v, len, cost;
    while(scanf("%d %d %d",&K,&n,&m) != EOF)
    {
        num = 0;
        result = INF;
        memset(next,-1,sizeof(next));
        memset(vis,0,sizeof(vis));
        for(int i = 1; i <= m; ++i)
        {
            scanf("%d %d %d %d",&u,&v,&len,&cost);
            edges[num].v = v;
            edges[num].len = len;
            edges[num].cost = cost;
            edges[num].next = next[u];
            next[u] = num;
            num++;
        }
        vis[1] = 1;
        dfs(1,0,0);
        if(result != INF)
            printf("%d\n",result);
        else
            printf("-1\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值