ACM: 二分图最大匹配 图论题 poj 2…

                                                                              Gopher II

 

Description

The gopher family, having averted the canine threat, must face a new predator.

The are n gophers and m gopher holes, each at distinct (x, y) coordinates. A hawk arrives and if a gopher does not reach a hole in s seconds it is vulnerable to being eaten. A hole can save at most one gopher. All the gophers run at the same velocity v. The gopher family needs an escape strategy that minimizes the number of vulnerable gophers.

Input

The input contains several cases. The first line of each case contains four positive integers less than 100: n, m, s, and v. The next n lines give the coordinates of the gophers; the following m lines give the coordinates of the gopher holes. All distances are in metres; all times are in seconds; all velocities are in metres per second.

Output

Output consists of a single line for each case, giving the number of vulnerable gophers.

Sample Input

2 2 5 10
1.0 1.0
2.0 2.0
100.0 100.0
20.0 20.0

Sample Output

1

题意: 有n个鼠, m个洞, 要求每只老鼠去不超过s*v的距离找到洞, 否则就被老鹰吃掉. 现在要你求出最少

      被吃掉的数目.

解题思路:

        1.一个洞一只老鼠, 很明显二分图信息.

        2. 匈牙利算法二分图最大匹配水之.

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;
#define MAX 105

int n, m, s, v;
double g[MAX][MAX];
bool vis[MAX];
int p[MAX];
double gx[MAX], gy[MAX];
double hx[MAX], hy[MAX];

inline double max(double a,double b)
{
 return a > b ? a : b;
}

double getDist(double x1,double y1,double x2,double y2)
{
 return (x1-x2)*(x1-x2)+(y1-y2)*(y1-y2);
}

void read_graph()
{
 int i, j;
 for(i = 0; i < n; ++i)
  for(j = 0; j < m; ++j)
   g[i][j] = 0;

 for(i = 0; i < n; ++i)
  scanf("%lf %lf",&gx[i],&gy[i]);
 for(j = 0; j < m; ++j)
  scanf("%lf %lf",&hx[j],&hy[j]);

 for(i = 0; i < n; ++i)
 {
  for(j = 0; j < m; ++j)
  {
   g[i][j] = getDist(gx[i],gy[i],hx[j],hy[j]);
  }
 }
}

bool find(int u)
{
 for(int j = 0; j < m; ++j)
 {
  if(g[u][j] <= s*v*s*v && !vis[j])
  {
   vis[j] = true;
   if(p[j] == -1 || find(p[j]))
   {
    p[j] = u;
    return true;
   }
  }
 }
 return false;
}

int Edmonds()
{
 int result = 0;
 memset(p,-1,sizeof(p));
 for(int i = 0; i < n; ++i)
 {
  memset(vis,false,sizeof(vis));
  if(find(i)) result++;
 }
 return result;
}

int main()
{
// freopen("input.txt","r",stdin);
 while(scanf("%d %d %d %d",&n,&m,&s,&v) != EOF)
 {
  read_graph();
  printf("%d\n",n - Edmonds());
 }

 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值