ACM: 最大连续和O(N) 动态规划 toj…

                      Max Sum

描述

 

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

输入

 

The first line of the input contains an integer T(1<=T<=25) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

输出

 

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

样例输入

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

样例输出

Case 1:
14 1 4

Case 2:
7 1 6

 

题意: 求最大连续和, 求出序列的起始和末尾.

 

解题思路:

                1. O(n)的时间复杂度.

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 100005
const int INF = -(1<<29);

int n;
int a[MAX];
int begin, end;
int maxt;
int sum;

int main()
{
// freopen("input.txt","r",stdin);
 int i, j;
 int caseNum;
 int NUM = 1;
 scanf("%d",&caseNum);
 for(int k = 1; k <= caseNum; ++k)
 {
  scanf("%d",&n);
  for(i = 0; i < n; ++i)
   scanf("%d",&a[i]);

  begin = end = 0;
  sum = 0;
  maxt = INF;
  int temp = 0;
  for(i = 0; i < n; ++i)
  {
   sum += a[i];
   if(sum > maxt)
   {
    end = i;
    begin = temp;
    maxt = sum;
   }
   if(sum < 0)
   {
    temp = i+1;
    sum = 0;
   }
  }
  printf("Case %d:\n",k);
  printf("%d %d %d\n",maxt,begin+1,end+1);
  if(k != caseNum)
   printf("\n");
 }

 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值