ACM: 简单排序题 poj 2231 动动脑…

Moo Volume
Description
Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise.

FJ's N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.

Input

* Line 1: N

* Lines 2..N+1: The location of each cow (in the range 0..1,000,000,000).

Output

There are five cows at locations 1, 5, 3, 2, and 4.

Sample Input

5

1 5 3 2 4

Sample Output

40

Hint

INPUT DETAILS:

There are five cows at locations 1, 5, 3, 2, and 4.

OUTPUT DETAILS:

Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is (10+10+6+7+7) = 40.

题意: 计算出sum =  ∑(a[i] - a[j]);

解题思路:
                              1. 题目给10,000个点, O(n^2)的暴力方法不可取.
                              2. 只需要仔细观察,先排序,每项与其下一项的作用,(重复使用的次数).
                              问题分析:
                              假设现在数组排序后: — — ... — T— — — ... —
                                                                                                                K个                           n-1-K个
                              每项a[i+1] - a[i]项会用到的次数是 (n-1-K)*(K+1)*(a[i+1]-a[i]);

代码:
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cstdlib>
using namespace std;
#define MAX 10005

int n;
long long a[MAX];
long long sum;

int cmp(const void *a,const void *b)
{
      return (*(int*)a) - (*(int*)b);
}

int main()
{
//      freopen("input.txt","r",stdin);
      while(scanf("%d",&n) != EOF)
      {
            for(int i = 0; i < n; ++i)
                  scanf("%lld",&a[i]);
                 
            qsort(a,n,sizeof(a[0]),cmp);
            sum = 0;
            for(int i = 0; i < n-1; ++i)
            {
                  sum += (a[i+1]-a[i])*(n-i-1)*(i+1);
            }
           
            printf("%lld\n",sum*2);
      }
      return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值