poj1141 Brackets Sequence 括号序列

这道题早就该补上了,之前用string做的超时 就扔那了。。

经典的dp问题

Brackets Sequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24809 Accepted: 6983 Special Judge

Description

Let us define a regular brackets sequence in the following way: 

1. Empty sequence is a regular sequence. 
2. If S is a regular sequence, then (S) and [S] are both regular sequences. 
3. If A and B are regular sequences, then AB is a regular sequence. 

For example, all of the following sequences of characters are regular brackets sequences: 

(), [], (()), ([]), ()[], ()[()] 

And all of the following character sequences are not: 

(, [, ), )(, ([)], ([(] 

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]

Source

Northeastern Europe 2001
#include <iostream>
#include <cstring>
#include <cstdio>

#define MAX 0x3f3f3f3f
using namespace std;
int dp[111][111];
int vis[111][111];
char s[111];
void ans(int n)
{
    for(int i=n-1; i>=0; i--){
        for(int j=i; j<n; j++){
            if(i==j){
                dp[i][j]=1;
                continue;
            }
            else if(s[i]=='('&&s[j]==')'){
                if(dp[i][j]>dp[i+1][j-1]){
                    dp[i][j]=dp[i+1][j-1];
                    vis[i][j]=MAX;
                }
                if(i+1==j){
                    dp[i][j]=0;
                    vis[i][j]=MAX;
                }
            }
            else if(s[i]=='['&&s[j]==']'){
                if(dp[i][j]>dp[i+1][j-1]){
                    dp[i][j]=dp[i+1][j-1];
                    vis[i][j]=MAX;
                }
                if(i+1==j){
                    dp[i][j]=0;
                    vis[i][j]=MAX;
                }
            }
            for(int k=i; k<j; k++){
                if(dp[i][j]>dp[i][k]+dp[k+1][j]){
                    dp[i][j]=dp[i][k]+dp[k+1][j];
                    vis[i][j]=k;
                }
            }
        }
    }
}
void print(int i,int j)
{

    if(i>j) return;
    if(i==j){
        if(s[i]=='('||s[i]==')')cout<<"()";
        else cout<<"[]";
    }
    else{
        if(vis[i][j]==MAX){
            cout<<s[i];
            print(i+1,j-1);
            cout<<s[j];
        }
        else{
            int p=vis[i][j];
            print(i,p);
            print(p+1,j);
        }
    }

}
int main()
{
    while(gets(s)){
        memset(dp,MAX,sizeof(dp));
        int len=strlen(s);
        ans(len);
        print(0,len-1);
        cout<<endl<<endl;
    }
    return 0;
}

水平有限 写的不好
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值