二分贪心练习题-E5


  
  
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).  His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C  * Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

题意:
    先输入两数,表示牛舍数与要放下多少头牛,后面给出牛舍的位置(牛舍在一条直线),求出放完牛后有牛的牛舍之间最小距离中的最大值
分析:
    一定数量的牛舍,一个位置只能放一头牛,那么要放入的牛数量越多,牛舍之间距离相对越小,所以可以用二分法做,我用judge函数判断x距离下能否放下这C头牛,二分循环找出可以放下这C头牛的最大的两舍之间的最小距离。
吐槽:
    本题我提交了好多次,最后发下超时的原因竟然是cin的输入速度太慢,换成scanf就AC了
#include<iostream>
#include<stdio.h>
#include<string>
#include<algorithm>
#include<string.h>
using namespace std;
int m,n,a[100002];
bool judge(int x)
{
    int g=a[0],f=1;
    for(int i=0;i<n;i++)
    {
        if(a[i]-g>=x)
        {
            f=f+1;//符合距离要求,放下一头牛
            g=a[i];
            if(f>=m){return true;}访完了,可以
        }
    }
    return false;
}
int main()
{
    int k,max=-1,ans=0,beg,end,mid;
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&a[i]);  
        if(a[i]>max){max=a[i];}
    }
    sort(a,a+n);
    end=max-a[0];beg=1;
    ans=1;
    while(beg<=end)//逐步找出符合要求的最小距离,在诸多都可以放下C头牛的最小距离中找出最大值
    {
        mid=(end+beg)/2;
        if(judge(mid))
        {
            ans=mid;
            beg=mid+1;
        }
        else
        {
            end=mid-1;
        }
    }
    cout<<ans;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值