hdu2476(String painter)区间dp

                                            String painter

                         Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                               Total Submission(s): 6438    Accepted Submission(s): 3114


Problem Description

There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?

 Input

Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.

 Output

A single line contains one integer representing the answer.

Sample Input

zzzzzfzzzzz

abcdefedcba

abababababab

cdcdcdcdcdcd

 Sample Output

6

7

题意:给出两个字符串,有一把刷子可以将任意 i 到 j 都刷成一种字符,问从第一种字符串刷成第二种最少需要多少步。

思路:有两种刷的方式,一种是直接在第一种基础上刷过去,还可以把初始形态当做空白直接刷成第二种字符串,所以我们要两种结合出最少步数。

1,先dp求出空白串刷成第二种,dp[i][j]表示字符串从第 i 个到第 j 个需要最少步数,初始条件:dp[i][j]=dp[i+1][j]+1;
      对于k=(i+1...j )如果s2[k]==s2[i],则dp[i][j]=min(dp[i][j],dp[i+1][k]+dp[k+1][j]),,因为刷i的时候可以与k同时刷。

2,ans[i]表示将s1[0...i]刷成s2[0...i]的最小步数,if  s1[i]==s2[i]  则ans[i]=ans[i-1];
                                                                                 else ans[i]=min(ans[i],ans[j]+dp[j+1][i])  j<i;

#include <set>
#include <map>
#include <deque>
#include <stack>
#include <queue>
#include <time.h>
#include <vector>
#include <string>
#include <math.h>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <iomanip>
#include <iostream>
#include <algorithm>
#define PI acos(-1)
#define ll long long
#define inf 0x3f3f3f3f
#define ull unsigned long long
using namespace std;

int dp[105][105],a[105];
char s1[105],s2[105];
int dfs(int i,int j)
{
    if(dp[i][j]!=-1) return dp[i][j];
    if(i>j) return 0;
    if(i==j) return dp[i][j]=1;
    dp[i][j]=dfs(i+1,j)+1;
    for(int k=i+1;k<=j;k++)
    {
        if(s2[i]==s2[k]) dp[i][j]=min(dp[i][j],dfs(i+1,k)+dfs(k+1,j));
    }
    return dp[i][j];
}
int main()
{
    while(scanf("%s%s",s1,s2)!=EOF)
    {
        memset(dp,-1,sizeof(dp));
        memset(a,0,sizeof(a));
        int len=strlen(s1);
        for(int i=0;i<len;i++)
        {
            for(int j=i;j<len;j++) dfs(i,j);
        }
        for(int i=0;i<len;i++)
        {
            a[i]=dp[0][i];
            if(s1[i]==s2[i])
            {
                if(i==0) a[i]=0;
                else a[i]=a[i-1];
            }
            else
            {
                for(int j=0;j<i;j++) a[i]=min(a[i],a[j]+dp[j+1][i]);
            }
        }
        printf("%d\n",a[len-1]);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值