POJ 2240 Arbitrage(最短路)

28 篇文章 0 订阅

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.
Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
Sample Output

Case 1: Yes
Case 2: No

题目大意
不同种货币之间存在转换律,判断是否存在一种货币可通过转换增加自身到自身的转换率。

解题思路
每种货币代表一个节点,初始化自身到自身的转换率为1,对Floyd算法进行小小的变型,之后判断是否存在自身到自身转换率增加的情况。
另外通过建立容器对字符串进行标识会更简单,把字符串与int进行一一映射,然后字符串便可作为数组下标标识货币种类。

关键代码

#include <iostream>
#include<cstdio>
#include<map>
#include<cstring>
using namespace std;
#define INF 100000
double d[35][35];
int n,m;
map<string,int>s;
void floyd()
{
    for(int k=1; k<=n; k++)
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                d[i][j]=max(d[i][j],d[i][k]*d[k][j]);  //Floyd变型,有+变为*
}
int main()
{
    int countt=1;
    double rate;
    bool flag;
    string str1,str2,str;
    while(~scanf("%d",&n))
    {
        memset(d,0,sizeof(d));
        flag=false;
        if(n==0)break;
        for(int i=1; i<=n; i++)
        {
            cin>>str;
            s[str]=i;
            d[i][i]=1;
        }
        scanf("%d",&m);
        for(int i=1; i<=m; i++)
        {
            cin>>str1>>rate>>str2;
            d[s[str1]][s[str2]]=rate;
        }
        floyd();
        for(int i=1; i<=n; i++)
        {
            if(d[i][i]>1)
            {
                flag=true;
                break;
            }
        }
        if(flag)
            printf("Case %d: Yes\n",countt++);
        else
            printf("Case %d: No\n",countt++);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值