POJ 1026 Cipher(置换)

38 篇文章 0 订阅

Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; …; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message.

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.

Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output

BolHeol  b
C RCE

题目大意

题目中给出一种变换规则,然后根据这个规则对字符串中每个字符进行k次变换,输出最终的字符串。

解题思路

直接模拟是不存在的。
其实这个置换还不难理解,对于字符串中的每个字符来说,每变换一次,就会被改变一个位置,而如果这个字符在一个长度为 x 的循环节中,那么经过 m 次轮换就会回到原位,所以原来的k次轮换很容易便可以转化为k%(所在的循环节长度)。

代码实现

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxn 207
char str[maxn],ans[maxn];   //原字符串、结果字符串
int vis[maxn],num[maxn],cir[maxn][maxn],a[maxn];
//求循环节时标记是否已被访问过、循环节长度、第i个循环节中第j个字符在原字符串中的位置、置换规则
int countt,n;
void handle()
{
    memset(vis,0,sizeof(vis));
    memset(cir,0,sizeof(cir));
    memset(num,0,sizeof(num));
    countt=0;
    for(int i=1;i<=n;i++)
    {
        if(!vis[i])
        {
            vis[i]=1;
            int temp=a[i];
            cir[countt][num[countt]++]=temp;
            while(!vis[temp])
            {
                vis[temp]=1;
                temp=a[temp];
                cir[countt][num[countt]++]=temp;
            }
        }
        countt++;
    }
}

int main()
{
    int k;
    while(~scanf("%d",&n))
    {
        if(n==0)break;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        handle();
        while(~scanf("%d",&k))
        {
            if(k==0) break;
            gets(str);
            for(int i=strlen(str);i<=n;i++)
                str[i]=' ';
            for(int i=0;i<countt;i++)
                for(int j=0;j<num[i];j++)
                    ans[cir[i][(j+k)%num[i]]]=str[cir[i][j]];
            ans[n+1]='\0';
            printf("%s\n",ans+1);
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值