山东省第八届ACM省赛 quadratic equation(简单数学)

13 篇文章 0 订阅
13 篇文章 0 订阅

Problem Description

With given integers a,b,c, you are asked to judge whether the following statement is true: “For any x, if ax2+bx+c=0 a ⋅ x 2 + b ⋅ x + c = 0 , then x is an integer.”

Input

The first line contains only one integer T(1≤T≤2000), which indicates the number of test cases.
For each test case, there is only one line containing three integers a,b,c(−5≤a,b,c≤5).

Output

or each test case, output “YES” if the statement is true, or “NO” if not.

Sample Input

3
1 4 4
0 0 1
1 3 1

Sample Output

YES
YES
NO

解题思路

命题的理解:
如果 ax2+bx+c=0 a ⋅ x 2 + b ⋅ x + c = 0 成立,且解x均为正数,输出”YES”;
如果 ax2+bx+c=0 a ⋅ x 2 + b ⋅ x + c = 0 不成立即不存在x使得这个等式为0,输出“YES”.
注意考虑a,b,c为 0 时的特殊情况.

代码实现

#include<bits/stdc++.h>
using namespace std;
#define IO ios::sync_with_stdio(false);\
cin.tie(0);\
cout.tie(0);
typedef long long ll;
const ll mod = 1e9+7;
#define INF 0x3f3f3f3f
const int maxn = 1e5+7;
int main()
{
    IO;
    int T;
    int a,b,c;
    cin>>T;
    while(T--)
    {
        bool flag=false;
        cin>>a>>b>>c;
        if(a!=0)
        {
            int t=b*b-4*a*c;
            if(t>=0)
            {
                int sqr=sqrt(t);
                if(sqr*sqr==t)
                {
                    if((-b+sqr)%(2*a)==0&&(-b-sqr)%(2*a)==0)
                    {
                        flag=true;
                    }
                }
            }
            else
                flag=true;
        }
        else if(a==0&&b!=0)
        {
            if(-c%b==0) flag=true;
        }
        else if(a==0&&b==0&&c!=0) flag=true;
        if(flag) cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值