UVa673 Parentheses Balance

70 篇文章 0 订阅
69 篇文章 0 订阅


Parentheses Balance
You are given a string consisting of parentheses () and []. A string of this type is said to be correct:


(a)if it is the empty string(b)if A and B are correct, AB is correct,(c)if A is correct, (A) and [A] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.


Input


The file contains a positive integer n and a sequence of n strings of parentheses () and [], one string a line.


Output


A sequence of Yes or No on the output file.


Sample Input


?
1
3
?
1
2
3
([])
(([()])))
([()[]()])()
Sample Output


?
1
2
3
Yes
No
Yes
 


 
#include <iostream>
#include <stack>
#include <map>
using namespace std;
int main(){
	
	int n;
	cin>>n;
	while(n--){
		stack <char> temp1;
		stack <char> temp2;
		map<char,char> kuohao;
		kuohao['(']=')';
		kuohao[')']='(';
		kuohao['[']=']';
		kuohao[']']='[';
		string str;
		cin>>str;
		for(int i=0;i<str.length();i++){
			temp1.push(str[i]);
		}
		temp2.push(temp1.top());
		temp1.pop();
		while(!temp1.empty()&&!temp2.empty()){
			//cout<<temp1.top()<<' '<<temp2.top()<<endl; 
			if(kuohao[temp1.top()]==temp2.top()){
				temp1.pop();
				temp2.pop();
				if(temp2.empty()&&!temp1.empty()){
					temp2.push(temp1.top());
					temp1.pop();
				}
			}
			else{
				temp2.push(temp1.top());
				temp1.pop();
			}	
		}
		
		if(temp1.empty()&&temp2.empty())
			cout<<"Yes"<<endl;
		else
			cout<<"No"<<endl;
	}
	
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值