HDU 5950 Recursive sequence(矩阵快速幂)

Recursive sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 437    Accepted Submission(s): 220


Problem Description
Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and i4 . Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right.
 

Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b < 231 as described above.
 

Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
 

Sample Input
  
  
2 3 1 2 4 1 10
 

Sample Output
  
  
85 369
Hint
In the first case, the third number is 85 = 2*1十2十3^4. In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.
 

Source

题意:已知f(i)=2f(i-2)+f(i-1)+i的4次方。给出f(1)和f(2)和n,求f(n)mod2147493647。
思路:一眼扫过去就觉得应该用矩阵快速幂,然而因为有i的4次方所以一开始放弃了这个思路转而去推公式。然而最终还是用矩阵快速幂,不过要构造一个7x7的矩阵来解决,很巧妙。只要把矩阵构造出来,其他的直接套模板即可。

#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>
#include <math.h>
using namespace std;
long long mod=2147493647UL;

struct matrix{
	long long m[7][7];
}E,A;

void init(){
	for(int i=0;i<7;i++){
		for(int j=0;j<7;j++)
			E.m[i][j]=(i==j);
	}
}

matrix mul(matrix A,matrix B){
	matrix ans;
	for(int i=0;i<7;i++){
		for(int j=0;j<7;j++){
			ans.m[i][j]=0;
			for(int k=0;k<7;k++){
				ans.m[i][j]+=(A.m[i][k]%mod)*(B.m[k][j]%mod)%mod;
			}
		}
	}
	return ans;
}

matrix quickmod(matrix A,int n){
	matrix t=A,d=E;
	while(n>0){
		if(n&1)
			d=mul(d,t);
		n>>=1;
		t=mul(t,t);
	}
	return d;
}

int main(){
	
	int t;
	scanf("%d",&t);
	while(t--){
		long long a,b,n;
		scanf("%lld %lld %lld",&n,&a,&b);
		if(n==1)
			printf("%lld\n",a);
		else if(n==2){
			printf("%lld\n",b);
		}
		else{
			init(); 
			A.m[0][0]=1;A.m[0][1]=2;A.m[0][2]=1;A.m[0][3]=4;A.m[0][4]=6;A.m[0][5]=4;A.m[0][6]=1; 
			A.m[1][0]=1;A.m[1][1]=0;A.m[1][2]=0;A.m[1][3]=0;A.m[1][4]=0;A.m[1][5]=0;A.m[1][6]=0; 
			A.m[2][0]=0;A.m[2][1]=0;A.m[2][2]=1;A.m[2][3]=4;A.m[2][4]=6;A.m[2][5]=4;A.m[2][6]=1; 
			A.m[3][0]=0;A.m[3][1]=0;A.m[3][2]=0;A.m[3][3]=1;A.m[3][4]=3;A.m[3][5]=3;A.m[3][6]=1; 
			A.m[4][0]=0;A.m[4][1]=0;A.m[4][2]=0;A.m[4][3]=0;A.m[4][4]=1;A.m[4][5]=2;A.m[4][6]=1; 
			A.m[5][0]=0;A.m[5][1]=0;A.m[5][2]=0;A.m[5][3]=0;A.m[5][4]=0;A.m[5][5]=1;A.m[5][6]=1; 
			A.m[6][0]=0;A.m[6][1]=0;A.m[6][2]=0;A.m[6][3]=0;A.m[6][4]=0;A.m[6][5]=0;A.m[6][6]=1; 
			matrix ans=quickmod(A,n-2);
			long long sum=(ans.m[0][0]*b%mod+ans.m[0][1]*a%mod+(ans.m[0][2]*16)%mod+(ans.m[0][3]*8)%mod+(ans.m[0][4]*4)%mod+
			ans.m[0][5]*2%mod+ans.m[0][6]%mod)%mod;
			printf("%lld\n",sum);
		}
	}
	return 0;
} 


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值