HDU 5980 Find Small A(水题)

Find Small A

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 86    Accepted Submission(s): 50


Problem Description
As is known to all,the ASCII of character 'a' is 97. Now,find out how many character 'a' in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits).
 

Input
The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤ ai ≤2^32 - 1) follow
 

Output
Output one line,including an integer representing the number of 'a' in the group of given numbers.
 

Sample Input
  
  
3 97 24929 100
 

Sample Output
  
  
3
 

Source

题意:给出一个数字代表一个4位的字符(讲真一开始我怎么读都没明白),就是说一个数可以用32位二进制表示,每8位代表一个字符(ASCII码),问给出的数字里面包含多少个A(即ASCII码为97)。
思路:明白题意之后一开始还是想复杂了,想把一个数字转化为二进制再做,但后来发现只要直接移位然后清高位保留低八位判断是否等于97即可。WA了一次是因为中间循环条件的设置,不应该判断是否为0,因为有可能正好有一个数字中间有某个8位恰好为0。因此还是老老实实移32位之后再跳出保险。

#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#include <math.h>
using namespace std;

int main(){
	
	int n;
	while(~scanf("%d",&n)){
		long long cnt=0;
		long long p=pow(2,8)-1;
		for(int i=0;i<n;i++){
			long long d;
			scanf("%lld",&d);
			long long temp=d;
			int j=0;
			while(j<=4){
				int k=8*j;
				j++;
				temp=d>>k;
				temp=temp&p;
				if(temp==97)
					cnt++;
			}
		}
		printf("%lld\n",cnt);
	}
	return 0;
} 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值