UVA 11300-Spreading the Wealth(中位数)

 F. Spreading the Wealth 

Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village.n lines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4

                                                                                  

题意:

给出n个数(n<1000001),将所有的硬币平均分配,最后相等。但是硬币只能在相邻两个数之间交换,所有人形成一个圈。要求得到最少流动的硬币数。

思路:

得到平均数c,xi 指的是第i 个人给第 i+1个人的数目;

a1 + xn - x1 = c;

a2 + x1 - x2 = c;

a3 + x2 - x3 = c;

....

用x1 替代x2,x3...;

得到 |x1| + |x1 - (c - a1)| + |x1 -  (c+c - a1-a2)| + ....为答案; 所以得到x1 为中位数得到的答案最小。

CODE:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

ll n[1000005], p[1000005];

int main()
{
    //freopen("in" , "r", stdin);
    int T;
    while(~scanf("%d", &T)){
        ll sum = 0;
        for(int i = 0; i < T; i++){
            scanf("%lld", &n[i]);
            sum += n[i];
        }
        ll c = sum/T;
        p[0] = 0;
        for(int i = 1; i < T; i ++){
            p[i] = p[i - 1] + c - n[i];
        }
        sort(p, p + T);
        ll t = p [T/2];
        ll ans = 0;
        for(int i = 0;i < T; i ++){
            ans += abs(t - p[i]);
        }
        printf("%lld\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值