Instability(Ramsey定理+快速幂)

Instability

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 154    Accepted Submission(s): 57


Problem Description
Long long ago, there was a prosperous kingdom which consisted of n cities and every two cites were connected by an undirected road.

However, one day a big monster attacked the kingdom and some roads were destroyed. In order to evaluate the influence brought by the catastrophe, the king wanted to know the instability of his kingdom. Instability is defined as the number of the unstable subset of {1, 2, ,n}.

A set S is unstable if and only if there exists a set A such that  AS(|A|3 ) and A is a  clique or an  independent set, namely that cites in A are pairwise connected  directly or they are pairwise disconnected.

Archaeologist has already restored themroads that were not destroyed by the monster. And they want you to figure out the instability.

Since the answer may be tremendously huge, you are only required to write a program that prints the answer modulo 1000000007.
 

Input
The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains two integers n ( 3n50 ) and m ( 1mn(n1)/2 ), indicating the number of cities and the number of roads.

Then the following are m lines, each of which contains two integers x and y, indicating there is a road between the city x and the city y.

It is guarenteed that there does not exist a road connecting the same city and there does not exist two same roads.
 

Output
For each test case, print a line “Case #x: y”, where x is the case number (starting from 1) and y is an integer indicating the instability modulo 1000000007.
 

Sample Input
  
  
2 4 3 1 2 2 3 1 3 3 0
 

Sample Output
  
  
Case #1: 2 Case #2: 1
Hint
• In the first example, {1,2,3} and {1,2,3,4} , containing the subset {1,2,3} which is connected directly, are considered unstable. • In the second example, {1,2,3} is considered unstable because they are not pairwise connected directly.
 

Source


Ramsey定理:6个人中至少3个人相互认识或相互不认识。所以这对于这题,6以上的点就不用考虑了,直接暴力求3,4,5个点的情况。先求出所有的子集,然后减去不满足的即可。

#include<iostream>
#include<string.h>
#include<algorithm>
#include<cstdio>
#include<vector>
int road[55][55];
const int Mod=1000000007;
long long fun(long long x,long long n)  
{  
    long long res=1;  
    while(n>0)  
    {  
        if(n & 1)  
            res=(res*x)%Mod;  
        x=(x*x)%Mod;  
        n >>= 1;  
    }  
    return res;  
}  
int check(int i,int j,int k)
{
	if(road[i][j]+road[i][k]+road[j][k]==0)
		return 1;
	if(road[i][j]+road[i][k]+road[j][k]==3)
		return 1;
	return 0;
}
int main()
{
	int cas;
	scanf("%d",&cas);
	int nn=0;
	while(cas--)
	{
		memset(road,0,sizeof(road));
		int n,m;
		scanf("%d%d",&n,&m);
		int u,v;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d",&u,&v);
			road[u][v]=1;
			road[v][u]=1;
		}
		long long ans=fun(2,n);
		ans=(ans-1+Mod)%Mod;
		ans=(ans-n+Mod)%Mod;
		ans=(ans-n*(n-1)/2)%Mod;
		for(int i=1;i<=n;i++)
		{
			for(int j=i+1;j<=n;j++)
			{
				for(int k=j+1;k<=n;k++)
				{
					if(check(i,j,k)==0)
						ans=(ans-1+Mod)%Mod;
				}
			}
		}
		for(int i=1;i<=n;i++)
		{
			for(int j=i+1;j<=n;j++)
			{
				for(int k=j+1;k<=n;k++)
				{
					for(int ll=k+1;ll<=n;ll++)
					{
					   if(check(i,j,k)==0&&check(i,j,ll)==0&&check(i,k,ll)==0&&check(ll,j,k)==0)
						ans=(ans-1+Mod)%Mod;
					}
				}
			}
		}
		for(int i=1;i<=n;i++)
		{
			for(int j=i+1;j<=n;j++)
			{
				for(int k=j+1;k<=n;k++)
				{
					for(int ll=k+1;ll<=n;ll++)
					{
						for(int lll=ll+1;lll<=n;lll++)
						{
							if(check(i,j,k)==0&&check(i,j,ll)==0&&check(i,j,lll)==0&&
								check(i,k,ll)==0&&check(i,k,lll)==0&&check(i,ll,lll)==0
								&&check(ll,j,k)==0&&check(lll,j,k)==0&&check(k,ll,lll)==0&&check(j,ll,lll)==0)
						      ans=(ans-1+Mod)%Mod;
						}
					}
				}
			}
		}
		printf("Case #%d: %lld\n",++nn,ans);
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值