[ACM] 1016 Prime Ring Problem (深度优先搜索)

286 篇文章 140 订阅
23 篇文章 0 订阅

Prime Ring Problem



Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source



题外话:

省赛的失利也不能阻挡我前进的脚步,经历过就是一件好事,正如老师所说的,结果谁也没法预测,但这个过程是实实在在的,自己可以在其中收获很多东西。人生中需要经历很多事情,有些事情,只有亲身经历过才会懂。

解题思路:

素数环要求任何相邻的两个数相加的和必须为素数。用DFs,从一年前期末考试两个多小时也没做出来这个题到现在的一次Ac,自己真的进步了。

代码:

#include <iostream>
#include <algorithm>
#include <string.h>
#include <cmath>
using namespace std;
const int maxn=25;
bool visit[maxn];
int num[maxn];
int n;

bool prime(int n)
{
    if(n==1)
        return false;
    if(n==2)
        return true;
    if(n%2==0)
        return false;
    for(int i=3;i<=(int)sqrt(n);i+=2)
        if(n%i==0)
        return false;
    return true;
}

void dfs(int step)
{
    if(step>n&&prime(num[n]+num[1]))
    {
        for(int i=1;i<=n-1;i++)
            cout<<num[i]<<" ";
        cout<<num[n]<<endl;
    }
    for(int i=2;i<=n;i++)
    {
        num[step]=i;
        if(prime(num[step]+num[step-1])&&!visit[i])//继续向下搜索的条件
        {
            visit[i]=1;
            dfs(step+1);
            visit[i]=0;
        }
    }
}
int main()
{
    int c=1;
    while(cin>>n)
    {
        cout<<"Case "<<c++<<":"<<endl;
        memset(visit,0,sizeof(visit));
        num[1]=1;
        dfs(2);
        cout<<endl;
    }
    return 0;
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值