1112 Stucked Keyboard

1112 Stucked Keyboard
On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:
Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:
For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:
3
caseee1__thiiis_iiisss_a_teeeeeest
Sample Output:
ei
case1__this_isss_a_teest
分析:第一步找出坏掉的键。

第二步按顺序输出坏掉的键。
最后输出应该输出的键。

参考代码:

#include<iostream>
#include<string>
#include<vector>
#include<set>
using namespace std;

int main() {
	int is_true[250] = { 0 }, k, cnt, j;
	cin >> k;
	string str;
	cin >> str;

	set<char>res, res1;
	for (int i = 0; i < str.size(); i++) {            //寻找坏掉的键值
		cnt = 1; j = i + 1;
		while (j < str.size() && str[j] == str[i] && cnt < k) {
			j++;  cnt++;
		}
		if (cnt == k && !is_true[str[i]]) {            //连续出现k次,并且未确定是否是正确的键,暂时把它放到res中,当做坏掉的键。
			res.insert(str[i]);
		}
		else if (cnt < k) {                            //一定没坏
			is_true[str[i]] = 1; res.erase(str[i]);
		}
		i = j-1;
	}
	res1 = res;
	for (int i = 0; i < str.size(); i++) {
		if (res1.find(str[i]) != res1.end()) {
			cout << str[i];
			res1.erase(str[i]);
		}
		if (res1.size() == 0)break;
	}
	cout << endl;
	for (int i = 0; i < str.size(); i++) {
		if (res.find(str[i]) != res.end()) {
			cout << str[i];
			i += (k-1);
		}
		else {
			cout << str[i];
		}
	}

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值