Hdu2222 Keywords Search

Problem Description

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input

First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a’-‘z’, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.

Output

Print how many keywords are contained in the description.

Sample Input

1
5
she
he
say
shr
her
yasherhs

Sample Output

3

题目大意

给出多组数据,每组中先会输入n(n<10000)个小写字母组成的短字符串(len<=50),然后一个长字符串(len<=1000000)
询问在场字符串中可以匹配多少个短字符串。
虽然可以很暴力的对于每个短字符串都弄一次kmp,但是显然会超时
所以,要使用新的算法,比如:AC自动机(这是模板题啊~~~)

AC自动机是多模匹配算法,kmp是单模匹配算法(其实就是匹配的字符串是否大于1)
换种说法,kmp是找一个串是否为其他串的子串的,而AC自动机是找其他串是否为某个串的子串的。
AC自动机就是在trie上跑kmp,有一个像kmp中next数组的fail数组,当匹配失败了就跳过去继续匹配~

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;

#define L 1000010
#define N 500005

int tree[N][26],fail[N],p[N],vis[N],s[L],tot=0,len,n,t;
char ch[L];

void insert()
{
    int now=0;
    for (int i=1;i<=len;i++)
    {
        if (tree[now][s[i]]==0) tree[now][s[i]]=++tot;
        now=tree[now][s[i]];
    }
    p[now]+=1;
}

queue<int> Q;

void get()
{
    for (int i=0;i<=25;i++)
      if (tree[0][i]!=0) Q.push(tree[0][i]);
    while (!Q.empty())
    {
        int now=Q.front(); Q.pop();
        for (int i=0;i<=25;i++)
        {
            int v=tree[now][i],k=tree[fail[now]][i];//可以理解为压缩了fail链,提高效率
            if (v!=0) fail[v]=k,Q.push(v);
              else tree[now][i]=k;
        }
    }
}

void query()
{
    int now=0,ans=0;
    for (int i=1;i<=len;i++)
    {
        now=tree[now][s[i]];
        for (int j=now;j!=0;j=fail[j])
        {
            ans+=p[j];
            if (vis[j]==1) break;
            vis[j]=1;
            p[j]=0;
        }
    }
  printf("%d\n",ans);
}

void init()
{
    memset(tree,0,sizeof(tree));
    memset(p,0,sizeof(p));
    memset(fail,0,sizeof(fail));
    scanf("%d",&n);
    for (int i=1;i<=n;i++)
    {
        scanf("\n%s",ch+1);
        len=strlen(ch+1);
        for (int j=1;j<=len;j++)
          s[j]=int(ch[j]-'a');
        insert();    
    }
    get();
    scanf("\n%s",ch+1);
    len=strlen(ch+1);
    for (int i=1;i<=len;i++)
      s[i]=int(ch[i]-'a');
}

int main()
{
    scanf("%d",&t);
    for (int ii=1;ii<=t;ii++)
    {
        init();
        query();
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值