Lost Cows POJ - 2182(线段树)

N (2 <= N <= 8,000) cows have unique brands in the range 1…N. In a spectacular display of poor judgment, they visited the neighborhood ‘watering hole’ and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he’s not very good at observing problems. Instead of writing down each cow’s brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.
Input

  • Line 1: A single integer, N

  • Lines 2…N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.
    Output

  • Lines 1…N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.
    Sample Input
    5
    1
    2
    1
    0
    Sample Output
    2
    4
    5
    3
    1
    和hdu5592一样的题目。hdu5592的博客
    代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<set>
#define ll long long
using namespace std;

const int maxx=1e4+100;
struct node{
	int l;
	int r;
	int sum;
}p[maxx<<2];
int a[maxx],b[maxx];
int n;

inline void pushup(int cur)
{
	p[cur].sum=p[cur<<1].sum+p[cur<<1|1].sum;
}
inline void build(int l,int r,int cur)
{
	p[cur].l=l;
	p[cur].r=r;
	if(l==r) 
	{
		p[cur].sum=1;
		return ;
	}
	int mid=l+r>>1;
	build(l,mid,cur<<1);
	build(mid+1,r,cur<<1|1);
	pushup(cur);
}
inline void update(int pos,int cur)
{
	int L=p[cur].l;
	int R=p[cur].r;
	if(L==R)
	{
		p[cur].sum=0;
		return ;
	}
	int mid=L+R>>1;
	if(pos<=mid) update(pos,cur<<1);
	else update(pos,cur<<1|1);
	pushup(cur);
}
inline int query(int cur,int k)
{
	int L=p[cur].l;
	int R=p[cur].r;
	if(L==R) return L;
	if(k<=p[cur<<1].sum) return query(cur<<1,k);
	else return query(cur<<1|1,k-p[cur<<1].sum);
}
int main()
{
	int x;
	scanf("%d",&n);
	set<int> s;
	for(int i=1;i<n;i++) scanf("%d",&a[i]);
	build(1,n,1);
	for(int i=n-1;i>=1;i--)
	{
		b[i]=query(1,a[i]+1);
		update(b[i],1);
	}
	printf("%d\n",query(1,1));
	for(int i=1;i<n;i++) printf("%d\n",b[i]);
	return 0;
}

努力加油a啊,(o)/~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值