1092
A+B for Input-Output Practice (IV)
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 123979 Accepted Submission(s): 65589
Problem Description
Your task is to Calculate the sum of some integers.
Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
Sample Input
4 1 2 3 4
5 1 2 3 4 5
0
Sample Output
10
15
Author
lcy
题意概括:先输入一个数N, 然后输入N个数,让N个数进行累加,输出累加的和。如果输入的N为0,结束。
AC代码:
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner s = new Scanner(System.in);
while(s.hasNextInt())
{
int n = s.nextInt(), sum = 0;
if(n == 0)
{
break;
}
for(int i = 1; i <= n; i ++)
{
int a = s.nextInt();
sum += a;
}
System.out.println(sum);
}
}
}