Tic Tac Toe


一、题目描述

Tic Tac Toe is a child’s game played on a 3 by 3 grid. One player, X, starts by placing an X at an unoccupied grid position. Then the other player, O, places an O at an unoccupied grid position. Play alternates between X and O until the grid is filled or one player’s symbols occupy an entire line (vertical, horizontal, or diagonal) in the grid.
We will denote the initial empty Tic Tac Toe grid with nine dots. Whenever X or O plays we fill in an X or an O in the appropriate position. The example below illustrates each grid configuration from the beginning to the end of a game in which X wins.
… X… X.O X.O X.O X.O X.O X.O

… … … … .O. .O. OO. OO.

… … … …X …X X.X X.X XXX

Your job is to read a grid and to determine whether or not it could possibly be part of a valid Tic Tac Toe game. That is, is there a series of plays that can yield this grid somewhere between the start and end of the game?
Input
The first line of input contains N, the number of test cases. 4N-1 lines follow, specifying N grid configurations separated by empty lines.
Output
For each case print “yes” or “no” on a line by itself, indicating whether or not the configuration could be part of a Tic Tac Toe game.
Sample Input
2
X.O
OO.
XXX

O.X
XX.
OOO
Sample Output
yes
no

二、题目理解

在这里插入图片描述

三、代码展示

#include<stdio.h>
char plant[4][4];
int win(char c)
{
    int i,j;
    for(i=0;i<3;i++)
    {
        for(j=0;j<3&&plant[i][j]==c;j++)
        {
            if(j==2)
                return 1;
        }
        for(j=0;j<3&&plant[j][i]==c;j++)
        {
            if(j==2)
                return 1;
        }
    }
    for(i=0;i<3&&plant[i][i]==c;i++)
    {
        if(i==2)
            return 1;
    }
    for(i=0;i<3&&plant[i][2-i]==2;i++)
    {
        if(i==2)
            return 1;
    }
    return 0;
}
int main()
{
    int n,x,o;
    int flag;
    int i,j;
    while(scanf("%d",&n)!=EOF)
    {
        getchar();
        while(n--)
        {
            x=0;
            o=0;
            for(i=0;i<3;i++)
            {
                scanf("%s",plant[i]);
            }
            for(i=0;i<3;i++)
            {
                for(j=0;j<3;j++)
                {
                    if(plant[i][j]=='X')
                    {
                        x++;
                    }
                    if(plant[i][j]=='O')
                    {
                        o++;
                    }
                }
            }
            flag=1;
            if(win('X')&&win('O'))
            {
                flag=0;
            }
            if(win('X')&&x==o)
            {
                flag=0;
            }
            if(win('O')&&x!=o)
            {
                flag=0;
            }
            if(o>x||x-o>1)
            {
                flag=0;
            }
            if(flag==1)
                printf("yes\n");
            if(flag==0)
                printf("no\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值