Prime Time (数论打表)

题目:

Euler is a well-known matematician, and, among many other things, he discovered that the formula n 2 + n + 41 produces a prime for 0 ≤ n < 40. For n = 40, the formula produces 1681, which is 41 ∗ 41. Even though this formula doesn’t always produce a prime, it still produces a lot of primes. It’s known that for n ≤ 10000000, there are 47,5% of primes produced by the formula! So, you’ll write a program that will output how many primes does the formula output for a certain interval.

Input

Each line of input will be given two positive integer a and b such that 0 ≤ a ≤ b ≤ 10000. You must read until the end of the file.

Output

For each pair a, b read, you must output the percentage of prime numbers produced by the formula in this interval (a ≤ n ≤ b) rounded to two decimal digits.

Sample Input

0 39 0 40 39 40

Sample Output

100.00 97.56 50.00

题意:

判断给出的区间中的每个整数对应的数(i*i+i+41)为质数的概率;

分析:

由于数据很小,直接打表,然后计算出区间的满足条件的数的个数,除以总区间内整数的个数即可;

代码:

#include<stdio.h>
#include<math.h>
using namespace std;
double eps=1e-8;
const int maxn=10005;
int prim[maxn];
bool primary(int n)
{
    int m=sqrt(n+0.5);
    for(int i=2;i<=m;i++)
        if(n%i==0) return 0;
    return 1;
}
int main()
{
    int i,a,b;
    prim[0]=1;
    for(i=1;i<=10000;i++)
        prim[i]=prim[i-1]+primary(i*i+i+41);
    while(scanf("%d %d",&a,&b)!=EOF)
    {
        int res=prim[b]-prim[a-1];
        printf("%.2lf\n",res*100.0/(b-a+1)+eps);//题目中没有说数据最后一位不是4 5就说明需要我们自己四舍五入
    }
    return 0;
}
 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值