(ZOJ 3469)Food Delivery 区间DP

Description
When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person’s coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain BiDispleasure Index per minute.

If one’s Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people’s Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input
The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

Output
For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input
5 1 0
1 1
2 2
3 3
4 4
5 5

Sample Output
55

题意:
一条直线上,有一些需要送饭的客户,每一个客户有一个位置以及不满意度,不满意度随着时间的增加而增加。问:给你餐馆的位置,送餐速度以及客户的位置及不满意度,求送餐完毕时所有客户最小的不满意度。

分析:

刚开始时没有认真读这句话,结果理解错了题意:As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant。
服务员是出发后送完所有的食物后返回,(一次性送完)。所以就很类似于“天上掉馅饼”的那一题了。是一道区间DP的题。

**关键:**Your speed is V^-1 meters per minute.速度为V分之一,s/v=t;所以t = s*V.所以我们用路程来代替时间,最后在乘上V即可。

状态:设dp[i][j][k] 表示送完i~j个人后最小的不满意度,k=0时表示送完后停留在i处,k=1表示送完后停留在j处。
假设我们求dp[i][j][0] 时(最后一个送的是i),那么dp[i][j][0]和dp[i+1][j][0]与dp[i+1][j][1]有关。当从第i+1个人到第i个人时,除了第i+1~第j个人以外,其他人都在等,所以不满意度都要加上去。所以我们用sum[i]表示前i个人的每分钟不满意度之和,cus[i].x表示第i个人的位子,cus[i].b表示第i个人的不满意度。

所以状态转移方程:
dp[i][j][0] = min(dp[i][j][0],dp[i+1][j][0]+(sum[i]+sum[n]-sum[j])*(cus[i+1].x-cus[i].x));
dp[i][j][0] = min(dp[i][j][0],dp[i+1][j][1]+(sum[i]+sum[n]-sum[j])*(cus[j].x-cus[i].x));
dp[i][j][1] = min(dp[i][j][1],dp[i][j-1][0]+(sum[i-1]+sum[n]-sum[j-1])*(cus[j].x-cus[i].x));
dp[i][j][1] = min(dp[i][j][1],dp[i][j-1][1]+(sum[i-1]+sum[n]-sum[j-1])*(cus[j].x-cus[j-1].x));

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;

const int inf = 0x3f3f3f;
const int maxn = 1005;
int sum[maxn];
int dp[maxn][maxn][2];
int X,V,n;

struct person
{
    int x,b;
};
person cus[maxn];

int cmp(person aa , person bb)
{
    return aa.x < bb.x;
}

int main()
{
    while(scanf("%d%d%d",&n,&V,&X)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d%d",&cus[i].x,&cus[i].b);
        n++;
        cus[n].x = X;
        cus[n].b = 0;
        sort(cus+1,cus+n+1,cmp);
        sum[0] = 0;
        for(int i=1;i<=n;i++)
            sum[i] = sum[i-1] + cus[i].b;
        int tmp;
        for(int i=1;i<=n;i++)
            if(cus[i].x == X)
            {
                tmp = i; break;
            }
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                dp[i][j][0] = dp[i][j][1] = inf;
        dp[tmp][tmp][0] = dp[tmp][tmp][1] = 0;
        for(int i=tmp;i>=1;i--)
        {
            for(int j=tmp;j<=n;j++)
            {
                if(i == j) continue;
                dp[i][j][0] = min(dp[i][j][0],dp[i+1][j][0]+(sum[i]+sum[n]-sum[j])*(cus[i+1].x-cus[i].x));
                dp[i][j][0] = min(dp[i][j][0],dp[i+1][j][1]+(sum[i]+sum[n]-sum[j])*(cus[j].x-cus[i].x));
                dp[i][j][1] = min(dp[i][j][1],dp[i][j-1][0]+(sum[i-1]+sum[n]-sum[j-1])*(cus[j].x-cus[i].x));
                dp[i][j][1] = min(dp[i][j][1],dp[i][j-1][1]+(sum[i-1]+sum[n]-sum[j-1])*(cus[j].x-cus[j-1].x));
            }
        }
        printf("%d\n",min(dp[1][n][0],dp[1][n][1])*V);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值