hdu 1062 Text Reverse

 
给个测试数据:
ab   bc
ba   cb
注意输出地空格
 
Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

Output
For each test case, you should output the text which is processed.
 

Sample Input
  
  
3 olleh !dlrow m'I morf .udh I ekil .mca
 

Sample Output
  
  
hello world! I'm from hdu. I like acm.
Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
 
 
#include <iostream>
using namespace std;
#include <string.h>
int main()
{
    int n,i,l,k,j;
    char a,b[1000];
    cin>>n;
    getchar();// 读取一个回车
    while(n--)
    {
        gets(b);
        l=strlen(b);
        k=0;
        for(i=0;i<l;i++)
        {   if(b[i]==32)\\如果是空格的话就输出,并且标记k指向后一个
              {
              cout<<" ";
              k=i+1;
        }
        else
            if(b[i+1]==32||b[i+1]=='\0')\\这个开始就写错了,还要判断最后一个是不是结束
            {
                for(j=i;j>=k;j--)
                    cout<<b[j];
                k=i+1;
            }
        }
            cout<<endl;
    }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值