UVA 10921 Find the Telephone

Problem B - Find the Telephone

Time Limit: 1 second

In some places is common to remember a phone number associating its digits to letters.In this way the expression MY LOVE means 69 5683. Of course there are someproblems, because some phone numbers can not form a word or a phrase and the digits1 and 0 are not associated to any letter.

Your task is to read an expression and find the corresponding phone number based onthe table below. An expression is composed by the capital letters (A-Z), hyphens (-) and the numbers 1 and 0.

LettersNumber
ABC2
DEF3
GHI4
JKL5
MNO6
PQRS7
TUV8
WXYZ9

Input

The input consists of a set of expressions. Each expression is in a line by itselfand has C characters, where 1 ≤ C ≤ 30. The input isterminated by enf of file (EOF).

Output

For each expression you should print the corresponding phone number.

Sample Input

1-HOME-SWEET-HOME
MY-MISERABLE-JOB

Sample Output

1-4663-79338-4663
69-647372253-562

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>
#include <queue>

using namespace std;
#define maxn 35
#define inf 0x7ffffff
pair <int ,int > p;
int arr[27];
char num[maxn];
int n;
//int cmpD(Node a,Node b){
//    return a.h > b.h;
//}
//int cmpI(Node a,Node b){
//    return a.h < b.h;
//}
int main()
{
    for(int i = 0; i < 18;i++){
        arr[i] = i / 3 + 2;
    }
    arr[18] = 7;
    arr[19] = arr[20] = arr[21] = 8;
    arr[22] = arr[23] = arr[24] = arr[25] = 9;
    while(gets(num)){
        for(int i = 0; num[i];i++){
            if(num[i] >= 'A' && num[i] <= 'Z'){
                printf("%d",arr[num[i] - 'A']);
            }else{
                printf("%c",num[i]);
            }
        }
        printf("\n");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值