FZU 2112K - Tickets

K - Tickets
Time Limit:3000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

FZU 2112
Description
You have won a collection of tickets on luxury cruisers. Each ticket can be used only once, but can be used in either direction between the 2 different cities printed on the ticket. Your prize gives you free airfare to any city to start your cruising, and free airfare back home from wherever you finish your cruising.

You love to sail and don’t want to waste any of your free tickets. How many additional tickets would you have to buy so that your cruise can use all of your tickets?

Now giving the free tickets you have won. Please compute the smallest number of additional tickets that can be purchased to allow you to use all of your free tickets.

Input
There is one integer T (T≤100) in the first line of the input.

Then T cases, for any case, the first line contains 2 integers n, m (1≤n, m≤100,000). n indicates the identifier of the cities are between 1 and n, inclusive. m indicates the tickets you have won.

Then following m lines, each line contains two integers u and v (1≤u, v≤n), indicates the 2 cities printed on your tickets, respectively.

Output
For each test case, output an integer in a single line, indicates the smallest number of additional tickets you need to buy.
Sample Input
3
5 3
1 3
1 2
4 5
6 5
1 3
1 2
1 6
1 5
1 4
3 2
1 2
1 2
Sample Output
1
2
0

题意:判断要加几条边使得形成一条经过所有城市的通路。

判断欧拉通路。

代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
using namespace std;
int u[100005];
int main (void)
{
    int t;
    //cin>>t;
    scanf("%d",&t);
    while(t--)
    {
        memset(u,0,sizeof(u));
      int m,n;
       scanf("%d %d",&m,&n);
       for(int i=0;i<n;i++)
       {
        int x,y;
        scanf("%d %d",&x,&y);
        u[x]++;
        u[y]++;
       }
       int ans=0;
       for(int i=0;i<=m;i++)
         {
            ans+=u[i]%2;//奇度数点多出来几条边
         }
         ans=(ans-2)/2;//补边
         if(ans<0)
            printf("0\n");
         else
            printf("%d\n",ans);
    }
    return 0;
}//欧拉通路
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值