HDOJ 5747Aaronson

Recently, Peter saw the equation  x0+2x1+4x2+...+2mxm=n . He wants to find a solution  (x0,x1,x2,...,xm)  in such a manner that  i=0mxi  is minimum and every  xi  ( 0im ) is non-negative.
 

Input
There are multiple test cases. The first line of input contains an integer  T   (1T105) , indicating the number of test cases. For each test case:

The first contains two integers  n  and  m   (0n,m109) .
 

Output
For each test case, output the minimum value of  i=0mxi .
 

Sample Input
  
  
10 1 2 3 2 5 2 10 2 10 3 10 4 13 5 20 4 11 11 12 3
 

Sample Output
  
  
1 2 2 3 2 2 3 2 3 2

一.分析和总结

简单思考一下发现问题并不是很难,但是又一个坑要处理一下,就是如果当m大于32时从32开始处理就好了
//
//  main.cpp
//  HDOJ 5747 Aaronson
//
//  Created by 张嘉韬 on 16/7/24.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
long long  pow1(long long x,long long n)
{
    long long temp;
    if(n==0) return 1;
    if(n==1) return x;
    else if(n%2==0)
    {
        temp=pow1(x,n/2);
        return temp*temp;
    }
    else
    {
        n=n-1;
        temp=pow1(x,n/2);
        return temp*temp*x;
    }
}

int main(int argc, const char * argv[]) {
    //freopen("/Users/zhangjiatao/Documents/暑期训练/input.txt","r",stdin);
    int T;
    cin>>T;
    for(int t=1;t<=T;t++)
    {
        long long n,m,sum;
        sum=0;
        cin>>n>>m;
        if(m>=32) m=32;
        while(n!=0)
        {
            long long k=0;
            long long temp=pow1(2,m);
            k=n/temp;
            n=n-k*temp;
            sum+=k;
            m--;
        }
        cout<<sum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值