POJ2689-Prime Distance(区间素筛)

9 篇文章 0 订阅
1 篇文章 0 订阅

Prime Distance
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20161 Accepted: 5424
Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).
Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.
Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.
Sample Input

2 17
14 17
Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.
题目:POJ2689
题意:给定一个区间[l,u],求区间内相邻最近和最远的两个质数并输出。
思路:(废话,可以直接跳至第二段)题意很简单,查找区间素数并输出即可。但是(1<=l,u<=2,147,483,647),用素筛去筛的话,不说数组是否开的下,时间也会TLE。注意到题目中说|u-l|<=1000000。也就是说,我们真正需要的素数的区间范围只有1e6。我们都会素筛这个算法,能否改进一下这个算法,只求得我们需要的区间的素数呢?
如果我们要求一个数n是否是素数,我们只需要判断n/(2~sqrt(n))==0?即可。那么同理我们要筛出n这个数是否为素数,也只需要用2~sqrt(n)就可以筛出
那么对于这道题,我们只需要用2~sqrt(u)去筛选[l,u],就可以筛出[l,u]间的素数,求的我们想要的答案了。具体实现见代码。
AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
#include<math.h>
#define met(s,k) memset(s,k,sizeof s)
#define scan(a) scanf("%d",&a)
#define scanl(a) scanf("%lld",&a)
#define scann(a,b) scanf("%d%d",&a,&b)
#define scannl(a,b) scanf("%lld%lld",&a,&b)
#define scannn(a,b,c) scanf("%d%d%d",&a,&b,&c)
#define prin(a) printf("%d\n",a)
#define prinl(a) printf("%lld\n",a)
using namespace std;
typedef long long ll;
const ll maxn=46400;//sqrt2,147,483,647int prime[maxn],big_prime[1000005];
ll min_prime[2],max_prime[2];
ll l,u;
void select(ll l,ll u)
{
    met(prime,0);
    met(big_prime,0);
    ll limit=(ll)sqrt((double)u);//每次筛到sqrt(u),即可得到想要的区间的素数
    for(ll i=2; i<=limit; i++)
    {
        if(!prime[i])
        {
            for(ll j=2*i; j<=limit; j+=i)prime[j]=1;//普通素筛
            for(ll j=(l/i+(l%i!=0))*i; j<=u&&j>0/*有可能最靠近l的i的倍数以及溢出了ll,注意RE*/; j+=i)if(j!=i)big_prime[j-l]=1;//j=(l/i+(l%i!=0))*i找出最靠近l的i的倍数,
        }
    }
}
int main()
{
    while(~scannl(l,u))
    {
        select(l,u);
        ll last=-1;
        max_prime[0]=-1,min_prime[0]=100000;
        if(l==1)big_prime[0]=1;
        for(int i=0; i<=(u-l); i++)
        {
            if(!big_prime[i])
            {
                if(last!=-1)
                {
                    if(i-last>max_prime[0])max_prime[0]=i-last,max_prime[1]=last;
                    if(i-last<min_prime[0])min_prime[0]=i-last,min_prime[1]=last;
                }
                last=i;
            }
        }
        if(max_prime[0]!=-1)printf("%lld,%lld are closest, %lld,%lld are most distant.\n",min_prime[1]+l,min_prime[1]+l+min_prime[0],max_prime[1]+l,max_prime[1]+l+max_prime[0]);
        else printf("There are no adjacent primes.\n");
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值