八、Identity Card

Problem Description
Do you own an ID card?You must have a identity card number in your family’s Household Register. From the ID card you can get specific personal information of everyone. The number has 18 bits,the first 17 bits contain special specially meanings:the first 6 bits represent the region you come from,then comes the next 8 bits which stand for your birthday.What do other 4 bits represent?You can Baidu or Google it.
Here is the codes which represent the region you are in.
这里写图片描述
However,in your card,maybe only 33 appears,0000 is replaced by other numbers.
Here is Samuel’s ID number 331004198910120036 can you tell where he is from?The first 2 numbers tell that he is from Zhengjiang Province,number 19891012 is his birthday date (yy/mm/dd).

Input
Input will contain 2 parts:
A number n in the first line,n here means there is n test cases. For each of the test cases,there is a string of the ID card number.

Output
Based on the table output where he is from and when is his birthday. The format you can refer to the Sample Output.

Sample Input

1
330000198910120036
2
810000190005120072

Sample Output

He/She is from Zhejiang,and his/her birthday is on 10,12,1989 based on the table.
He/She is from Hong Kong,and his/her birthday is on 05,12,1900 based on the table.

#include<iostream>
#include<stdio.h>
 #include<string.h>
using namespace std;     
int main()
{ 
    char a[8][10] ={"Zhejiang" , "Beijing" , "Taiwan","Hong Kong","Macao","Tibet","Liaoning","Shanghai"};
    char b[8][3] ={"33" ,"11","71" ,"81" ,"82","54" ,"21" ,"31"};
    int n,i ;
    char c[19];

    cin>>n;
    getchar();
    while(n--)
    { gets(c);


      for(i=0;i<8;i++)
        {if(strncmp(c,b[i],2)==0)
                break;}
            cout<<"He/She is from "<<a[i]<<",and his/her birthday is on "<<c[10]<<c[11]<<","<<c[12]<<c[13]<<","<<c[6]<<c[7]<<c[8]<<c[9]<<" based on the table."<<endl;


 }


    return 0;

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

sxj731533730

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值