单臂路由+DHCP小综合实验
实验拓扑如下:
要求如图所示,最终实现PC能自动获取IP地址,并能互相ping通。
思路:先将单臂路由配完,再配DHCP
路由器不能配vlan,二层交换机不能配ip
二层交换机的端口没有办法直接设IP地址,三层交换机端口可以在vlan上设置IP地址
命令整理如下:
R1:
第一步:hostname R1修改名字
Router>enable
Router#conf terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#
第二步:每个vlan都排除前10个地址
R1(config)#ip dhcp excluded-address 10.0.0.1 10.0.0.10
R1(config)#ip dhcp excluded-address 20.0.0.1 20.0.0.10
R1(config)#ip dhcp excluded-address 30.0.0.1 30.0.0.10
第三步:建立地址池
一个池只能有一个地址
R1(config)#ip dhcp pool VLAN10
R1(dhcp-config)#network 10.0.0.0 255.255.255.0
R1(dhcp-config)#default-router 10.0.0.254
R1(config)#ip dhcp pool VLAN20
R1(dhcp-config)#network 20.0.0.0 255.255.255.0
R1(dhcp-config)#default-router 20.0.0.254
R1(config)#ip dhcp pool VLAN30
R1(dhcp-config)#network 30.0.0.0 255.255.255.0
R1(dhcp-config)#default-router 30.0.0.254
除了network、default-router还可以配置dns-server、domain-name
第四步:配置子vlan
R1(config)#interface GigabitEthernet0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 10.0.0.254 255.255.255.0
R1(config)#interface GigabitEthernet0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 20.0.0.254 255.255.255.0
R1(config)#interface GigabitEthernet0/0.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip address 30.0.0.254 255.255.255.0
R1(config)#interface GigabitEthernet0/0
R1(config-if)#no shutdown //启用端口
show running-config查看做过的操作
S1:
配置四个端口
与用户相连的端口用access模式
S1(config)#interface fastEthernet 0/1
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 10
S1(config-if)#exit
S1(config)#interface fastEthernet 0/2
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 20
S1(config-if)#exit
S1(config)#interface fastEthernet 0/3
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 30
S1(config-if)#exit
S1(config)#
trunk模式
S1(config)#interface gigabitEthernet 0/1
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk allowed vlan 10,20,30
S1(config-if)#exit
S1(config)#