SPFA求次短路径

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1…N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input
Line 1: Two space-separated integers: N and R
Lines 2…R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output
Line 1: The length of the second shortest path between node 1 and node N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output
450
Hint
Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)
题意:题意就是让你找第二短的路径

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
const int N=200000;
int dis1[N],dis2[N],book[N];
int first[N],to[N],next[N],s[N],head;
void build(int x,int y,int z)
{
    next[head]=first[x];
    first[x]=head;
    s[head]=z;
    to[head++]=y;
}
void spfa(int x,int dis[])
{
    memset(dis,inf,sizeof(dis));
    memset(book,0,sizeof(book));
    dis[x]=0;
    book[x]=1;
    queue<int>q;
    q.push(x);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        book[u]=0;
        for(int i=first[u];i!=-1;i=next[i])
        {
            int k=to[i];
            if(dis[k]>dis[u]+s[i])
            {
                dis[k]=dis[u]+s[i];
                if(!book[k])
                {
                    book[k]=1;
                    q.push(k);
                }
            }
        }
    }
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(first,-1,sizeof(first));
        memset(dis1,inf,sizeof(dis1));
        memset(dis2,inf,sizeof(dis2));
        head=1;
        int x,y,z;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            build(x,y,z);
            build(y,x,z);
        }
        spfa(1,dis1);
        spfa(n,dis2);
        int sum=inf;
        for(int i=1;i<=n;i++)
        {
            for(int j=first[i];j!=-1;j=next[j])
            {
                int k=dis1[i]+dis2[to[j]]+s[j];
                if(k>dis1[n]&&sum>k)
                    sum=k;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值