第十三周训练 problem d

Problem Description
Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
 

Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
 

Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.
 

Sample Input
  
  
3 1 1 2 3 4 3
 

Sample Output
  
  
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
如果存在那样的路线,则从任意一点出发都一定能走遍全图,直接用dfs搜索。
注意!!答案要求从左到右,从下到上。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<map>
#include<queue>
#include<cmath>
#include<vector>
using namespace std;
bool vis[50][50];
int n,m;
int path[10000];
int dx[]={-1,1,-2,2, -2,2,-1,1};  //方向数组一定要这样写
int dy[]={-2,-2,-1,-1 ,1,1,2,2}; 
bool istrue(int x,int y)
{
	if(x>=0&&x<n&&y>=0&&y<m)
		return 1;
	return 0;
}
void out()
{
	for(int i=0;i<n*m;i++)
	{
		printf("%c%d",(path[i]%m)+'A',path[i]/m+1);
	}
	printf("\n");
}
bool dfs(int x,int y,int k)
{
	if(k==n*m)
	{
		out();
		return 1;
	}
	for(int i=0;i<8;i++)
	{
		if(istrue(x+dx[i],y+dy[i])&&!vis[x+dx[i]][y+dy[i]])
		{
			path[k]=(x+dx[i])*m+y+dy[i];
			vis[x+dx[i]][y+dy[i]]=1;
			if(dfs(x+dx[i],y+dy[i],k+1)) return 1;
			vis[x+dx[i]][y+dy[i]]=0;
		}
	}
	return 0;
}
int main()
{
	int t;
	scanf("%d",&t);
	for(int tt=1;tt<=t;tt++)
	{
		scanf("%d %d",&n,&m);
		printf("Scenario #%d:\n",tt);
		memset(vis,0,sizeof(vis));
		path[0]=0;
		vis[0][0]=1;			//把起点安排在0,0
		if(!dfs(0,0,1)) printf("impossible\n");
		printf("\n");
	}
    return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

TommyTT

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值