Problem C

Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
  
  
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
  
  
200 0 0
 

简单题意:

  田忌赛马是中国古代一个著名的故事,田忌用他最快的马先与齐王第二快的马比赛一场,然后用第二快的马与齐王最慢的马比赛,最后用最慢的马与齐王最快的马比赛。这样下来就能赢得200银币。现在要求编写一个程序,求出田忌每次赛马可以获得的最多金钱。

解题思路形成过程:

  第一思路是把田忌的马的速度从小到大排序,齐王的马从大到小排序。然后两层for循环,从田忌最慢的马开始比较,如果比齐王的中的马快,就跑一场。这样下来,肯定没有重复,也就得到最大的利益。但是一直没有AC。所以换了一种思路,田忌最快的马如果比齐王最快的马快,就跑一场。接下来,如果田忌最慢的马也比齐王的最慢马快,也跑一场。其他情况就是田忌输或者平局的情况。

感想:

  算法真不好想。因为经验的不足,很多层面都没有发散出去。跳跃性思维,发散思维,这才是ACM中最重要的。

AC代码:

  #include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main()
{
    int horseNum,k[1001],t[1001];
    while(cin>>horseNum&&horseNum!=0)
    {
        for(int i=0;i<horseNum;i++)
               cin>>t[i];
        sort(t,t+horseNum);
        for(int i=0;i<horseNum;i++)
            cin>>k[i];
        sort(k,k+horseNum);
        int sum=0,tMin=0,tMax=horseNum-1,kMin=0,kMax=horseNum-1;
        while(tMin<=tMax)
        {
            if(t[tMax]>k[kMax])
            {
                sum++;
                tMax--;
                kMax--;
            }
            else if(t[tMin]>k[kMin])
            {
                sum++;
                tMin++;
                kMin++;
            }
            else if(t[tMin]<k[kMax])
                {
                    sum--;
                    tMin++;
                    kMax--;
                }
            else {tMin++;kMax--;}
        }
        cout<<sum*200<<endl;
        }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值