Can you solve this equation?

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;<br>Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2<br>100<br>-4<br>
 

Sample Output
  
  
1.6152<br>No solution!<br>
简单题意:
  求出一个表达式的解;
解题思路形成过程:
  算法的优化是关键,采用二分法;
感想:
  这是一个简单的题目,并不需要太多的逻辑思维。
AC代码:
  #include <iostream>
#include <cmath>
#include <cstdio>
#include <algorithm>
double f(double x)
{
    return (8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6);
}
using namespace std;
int main()
{
    int t;
    cin>>t;
    for(int i=0;i<t;i++)
    {
        double y,mid;
        cin>>y;
        if(f(0)>y||f(100)<y)cout<<"No solution!"<<endl;
        else
        {
            double left=0,right=100;
            while(right-left>1e-10)
            {
                mid=(right+left)/2;
                if(f(mid)>y)
                    right=mid;
                else left=mid;
            }
            printf("%.4f\n",mid);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值