poj 1094 Sorting It All Out topological sorting

265 篇文章 1 订阅
15 篇文章 0 订阅
Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 25689 Accepted: 8917

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

Source


Typical topological sort, however, the testing data is not right. Here's an AC code:


#include<stdio.h>
#include<string.h>
using namespace std;
int adj[28][28]={0};
char sortRes[28]={'\0'};
int m,n;
int toposort() {
  int i,j,k,flg = 1, res = 1;
  int inDegrees[28] = {0};
  memset(sortRes, '\0', sizeof(sortRes));
  for (i = 0; i < n; ++i)
    for (j = 0; j < n; ++j)
      if (adj[i][j])
        ++inDegrees[j];

  for (i = 0; i < n; ++i) {
    k = -1;
    for (j = 0; j < n; ++j) 
      if (inDegrees[j] == 0) {
        if (k == -1)
          k = j;
        else
          flg = 0;
      }

      if (k == -1)
        return 0; //There is a circle
      else if (flg == 0)
        res = -1; //Multiple 0    
      for (j = 0; j < n; ++j)
        if (adj[k][j])
          --inDegrees[j];
      inDegrees[k] = -1;
      sortRes[i] = 'A' + k;
  }

  return res;  
}
int main() {
  char s[10];
  //freopen("test.txt","r",stdin);
  while (scanf("%d%d",&n,&m) != EOF && n != 0) {
    memset(adj, 0, sizeof(adj));
    int h = -2, flg = 0;
    for (int i = 0; i < m; ++i) {
      scanf("%s",s);
      if (flg == 0) {
        adj[s[0]-'A'][s[2]-'A'] = 1;      
        h = toposort();
        if (h == 0 || h == 1)
          flg = i + 1;
      }
    }
    if (h == 1)
      printf("Sorted sequence determined after %d relations: %s.\n",flg,sortRes);
    else if (h == 0)
      printf("Inconsistency found after %d relations.\n", flg);
    else if (h == -1)
      printf("Sorted sequence cannot be determined.\n");
  } 
  return 0; 
}

The general solution for topological sorting:

  for (i = 0; i < n; ++i)
    for (j = 0; j < n; ++j)
      if (adj[i][j])
        ++inDegrees[j];  //1. GET all in degrees

  for (i = 0; i < n; ++i) {
    k = -1;
    for (j = 0; j < n; ++j) 
      if (inDegrees[j] == 0) {  //2. Pick out the node with 0 in degree
        if (k == -1)
          k = j;
        else
          flg = 0;
      }
      // 3. The concepts of circle:3->1->2 && 3->4->2 is not a circle.Judge whether there's a circle or multiple 0s
      if (k == -1)
        return 0; //There is a circle
      else if (flg == 0)
        res = -1; //Multiple 0    
      for (j = 0; j < n; ++j)  //prepare for the next loop
        if (adj[k][j])
          --inDegrees[j];  
      inDegrees[k] = -1;
      sortRes[i] = 'A' + k;
  }


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值