Maximum Product UVA - 11059

7 篇文章 0 订阅

 注意:是序列,有顺序的,有顺序的,有顺序的。

Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3

2 4 -3

 

5

2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.

 

Case #2: The maximum product is 20.

#include <stdio.h>

int main()
{
    int num[100000];
    int h = 1, n, i, j;
    while(scanf("%d", &n) != EOF)
    {
        for(i = 0; i < n; i++)
        {
            scanf("%d", &num[i]);
        }
        long long maxn = 0;
        for(i = 0; i < n; i++)
        {
            long long product = 1;
            for(j = i; j < n; j++)
            {
                product *= num[j];
                if(product > maxn)
                {
                    maxn = product;
                }
            }
        }
        printf("Case #%d: The maximum product is %lld.\n", h++, maxn);
        printf("\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值