Periodic Strings

Description
Download as PDF
Periodic Strings
A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string “abcabcabcabc” has period 3, since it is formed by 4 repetitions of the string “abc”. It also has periods 6 (two repetitions of “abcabc”) and 12 (one repetition of “abcabcabcabc”).
Write a program to read a character string and determine its smallest period.
Input
The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.
Output
An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.
Sample Input
1

HoHoHo
Sample Output
2
一个字符串,问最少是多少个字符重复的。只用搜n/2次就好了,如果都不行,就是原来的长度。
写的时候要注意比较,容易出错。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<queue>
#include<algorithm>
using namespace std;
char a[105], b[105];
int check(int x,int step)
{
    int i, j, leap = 0;
    for (i = 1; i < step; i++)
    {
        for (j = i*x ; j < i*x + x; j++)
        {
            if (a[j] != a[j%x])leap = 1;
        }
    }
    if (leap)return 0;
    else return 1;
}
int main()
{
    int i, j, m, n, ans, t, len,step;
    cin >> t;
    getchar(); getchar();
    while (t--)
    {
        gets(a);
        len = strlen(a);
        for (i = 1; i <= len / 2; i++)
        {
            if (len%i != 0)continue;
            step = len / i;
            for (j = 0; j < i; j++)
                b[j] = a[j];
            if (check(i, step))break;
        }
        if (i == len / 2 + 1)cout << len << endl;
        else cout << i << endl;
        if (t != 0)cout << endl;
        if (t)getchar();
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值