poj 2955 Brackets

原题:
Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17392 Accepted: 9010

Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source
Stanford Local 2004

中文:

给你个括号序列,只由()和[]组成
问你最长的有效括号长度是多少?

代码:

//#include<bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<cstring>
using namespace std;
typedef long long ll;

typedef pair<int,int> pii;
const int maxn = 105;
char s[maxn];
int dp[maxn][maxn];

bool cmp(char c1,char c2)
{
    if(c1=='('&&c2==')')
        return true;
    if(c1=='['&&c2==']')
        return true;
    return false;
}

int main()
{
    ios::sync_with_stdio(false);
    while(cin>>&s[1])
    {
        if(s[1]=='e')
        {
            break;
        }
        int len = strlen(&s[1]);
        memset(dp,0,sizeof(dp));

        for(int i=1;i<len;i++)
        {
            if(cmp(s[i],s[i+1]))
                dp[i][i+1]=2;
        }

        for(int l=2;l<=len;l++)
        {
            for(int i=1;i<=len-l;i++)
            {
                int j=i+l;
                if(cmp(s[i],s[j]))
                    dp[i][j]=max(dp[i+1][j-1]+2,dp[i][j]);

                for(int k=i+1;k<j;k++)
                {
                    dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]);
                }
            }
        }

        cout<<dp[1][len]<<endl;
    }
    return 0;
}

解答:

简单的区间dp
输入括号序列s,状态转移方程如下

s [ i ] = = s [ j ] s[i]==s[j] s[i]==s[j]
d p [ i ] [ j ] = m a x ( d p [ i ] [ j ] , d p [ i + 1 ] [ j − 1 ] + 2 ) dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2) dp[i][j]=max(dp[i][j],dp[i+1][j1]+2)
否则
d p [ i ] [ j ] = m a x ( d p [ i ] [ j ] , d p [ i ] [ k ] + d p [ k ] [ j ] ) dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]) dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]) k ∈ ( i , j ) k ∈(i,j) k(i,j)

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值