uva 10382 Watering Grass

原题:
n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler
is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the
distance from the left end of the center line and its radius of operation.
What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?
这里写图片描述
Input
Input consists of a number of cases. The first line for each case contains integer numbers n, l and w
with n ≤ 10000. The next n lines contain two integers giving the position of a sprinkler and its radius
of operation. (The picture above illustrates the first case from the sample input.)
Output
For each test case output the minimum number of sprinklers needed to water the entire strip of grass.
If it is impossible to water the entire strip output ‘-1’.
Sample Input
8 20 2
5 3
4 1
1 2
7 2
10 2
13 3
16 2
19 4
3 10 1
3 5
9 3
6 1
3 10 1
5 3
1 1
9 1
Sample Output
6
2
-1
大意:
给你一个矩形,告诉你长宽,然后给你n个喷头。这些喷头都安装在矩形横向的中心线上。每个喷头给出到最左侧的距离和喷洒半径,现在问你最少用多少个喷头能把这个矩形完全覆盖。

#include <bits/stdc++.h>

using namespace std;

struct circle
{
    double st,en;
};
vector<circle> cir;
double len,wi;
int n;
double GetLen(double r)
{
    return sqrt((r*r)-(wi/2)*(wi/2));
}
int cmp(const circle &a,const circle &b)
{
    return a.st<b.st;
}
int main()
{
    ios::sync_with_stdio(false);
    int ans;
    while(cin>>n>>len>>wi)
    {
        ans=0;
        cir.clear();
        circle tmp;
        for(int i=1;i<=n;i++)
        {
            double p,r;
            cin>>p>>r;
            if(r<=wi/2)
                continue;
            tmp.st=p-GetLen(r);
            tmp.en=p+GetLen(r);
            cir.push_back(tmp);
        }
        sort(cir.begin(),cir.end(),cmp);
        double r=0;
        int j;
        for(int i=0;i<cir.size();)
        {
            if(cir[i].st>r)
                break;
            for(j=i+1;j<cir.size();j++)
            {
                if(cir[j].st>r)
                    break;
                if(cir[j].en>cir[i].en)
                    i=j;
            }
            ans++;
            r=cir[i].en;
            if(r>=len)
                break;
            i=j;
        }
        if(r>=len)
            cout<<ans<<endl;
        else
            cout<<-1<<endl;
    }
    return 0;
}

解答:
在半径的长度大于宽度的一半的情况下,先把每个喷头的圆形区域转换成和给出矩形宽度相交那部分的矩形区域,然后根据刘汝佳小白书p154页上的那个区间覆盖问题去做就好。
注意输入一定要用double!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值