hdoj 2795 Billboard

原题:

Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.

Sample Input
3 5 5
2
4
3
3
3

Sample Output
1
2
1
3
-1
中文:
给你一个长为高为h,宽为w的告示板,让你往上面贴宽度不一定,但是高度为1的各种小广告。每个小广告尽量靠左靠上,现在给你n个小广告,为这个小广告在第几行?

#include <bits/stdc++.h>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
const int maxn=222222;
int segTree[maxn<<2];
int h,w,n;
void pushup(int rt)
{
    segTree[rt]=max(segTree[rt<<1],segTree[rt<<1|1]);
}
void build(int l,int r,int rt)
{
    segTree[rt]=w;
    if(r==l)
        return;
    int m=(l+r)>>1;
    build(lson);
    build(rson);

}
int adhere(int a,int l,int r,int rt)
{
    if(r==l)
    {
        segTree[rt]-=a;
        return l;
    }
    int m=(l+r)>>1;
    int tmp=(segTree[rt<<1]>=a)?adhere(a,lson):adhere(a,rson);
    pushup(rt);
    return tmp;
}

int main()
{
    ios::sync_with_stdio(false);
    while(cin>>h>>w>>n)
    {
        if(h>n)
            h=n;
        build(1,h,1);
        for(int i=0;i<n;i++)
        {
            int a;
            cin>>a;
            if(segTree[1]<a)
                cout<<-1<<endl;
            else
                cout<<adhere(a,1,h,1)<<endl;
        }
    }

    return 0;
}

解答:
hh大神pdf上面推荐的题目,题倒是不难,自己写的代码交了好几次都是RE,后来照着pdf上面的代码敲了一遍,居然wa了,自己又改了半天,终于过了。
由于每次贴广告的时候都要靠左靠上,所以初始化的时候每一行的长度按照线段树都初始化为宽度w。然后每次查找左子树是否够这个广告的宽度,如果不够向右子树找即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值