LA 3027 Corporative Network

原题:
A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon, for amelioration of the services, the corporation started to collect some enterprises in clusters, each of them served by a single computing and telecommunication center as follow. The corporation chose one of the existing centers I (serving the cluster A) and one of the enterprises J in some other cluster B (not necessarily the center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I −J|(mod1000). In such a way the two old clusters are joined in a new cluster, served by the center of the old cluster B. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving center could be changed and the end users would like to know what is the new length. Write a program to keep trace of the changes in the organization
of the network that is able in each moment to answer the questions of the users.
Your program has to be ready to solve more than one test case.
Input
The first line of the input file will contains only the number T of the test cases. Each test will start with the number N of enterprises (5 ≤ N ≤ 20000). Then some number of lines (no more than 200000) will follow with one of the commands:
E I — asking the length of the path from the enterprise I to its serving center in the moment; I I J — informing that the serving center I is linked to the enterprise J. The test case finishes with a line containing the word ‘O’. The ‘I’ commands are less than N.
Output
The output should contain as many lines as the number of ‘E’ commands in all test cases with a single number each — the asked sum of length of lines connecting the corresponding enterprise with its serving center.
Sample Input
1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O
Sample Output
0
2
3
5

中文:
给你n个节点,初始每个节点的父节点都不存在。给你n条命令,其中
I u v 表示把节点u的父节点设置为v,u与v之间的距离为|v-v|%1000,输入保证u没有父节点
E u 表示输出u到根节点的距离
输入命令O表示结束

#include <bits/stdc++.h>
using namespace std;
int father[20001];
int dis[20001];
int n;
int get_dis(int x)
{
    if(father[x]!=x)
    {
        int f=get_dis(father[x]);
        dis[x]+=dis[father[x]];
        father[x]=f;
        return f;
    }
    return father[x];
}
void ini()
{
    for(int i=1;i<=n;i++)
        father[i]=i;
    memset(dis,0,sizeof(dis));
}
int main()
{
    ios::sync_with_stdio(false);
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        ini();
        string s;
        while(cin>>s)
        {
            if(s=="O")
                break;
            if(s=="E")
            {
                int res;
                cin>>res;
                get_dis(res);
                cout<<dis[res]<<endl;
            }
            if(s=="I")
            {
                int u,v;
                cin>>u>>v;
                father[u]=v;
                dis[u]=abs(u-v)%1000;
            }
        }
    }
    return 0;
}

思路:
训练指南上并查集的第二道例题,此题如何解很好想。就是在并查集路径压缩的过程当中把距离累加起来即可,不过,若是对递归理解的不好,代码如何写会是一个很大的问题。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值