uva 202 Repeating Decimals

原题:
The decimal expansion of the fraction 1/33 is 0.03, where the 03 is used to indicate that the cycle 03
repeats indefinitely with no intervening digits. In fact, the decimal expansion of every rational number
(fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have no
such repeating cycles.
Examples of decimal expansions of rational numbers and their repeating cycles are shown below.
Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.
这里写图片描述
Write a program that reads numerators and denominators of fractions and determines their repeating
cycles.
For the purposes of this problem, define a repeating cycle of a fraction to be the first minimal length
string of digits to the right of the decimal that repeats indefinitely with no intervening digits. Thus
for example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0
which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4).
Input
Each line of the input file consists of an integer numerator, which is nonnegative, followed by an integer
denominator, which is positive. None of the input integers exceeds 3000. End-of-file indicates the end
of input.
Output
For each line of input, print the fraction, its decimal expansion through the first occurrence of the cycle
to the right of the decimal or 50 decimal places (whichever comes first), and the length of the entire
repeating cycle.
In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If the
entire repeating cycle does not occur within the first 50 places, place a left parenthesis where the cycle
begins — it will begin within the first 50 places — and place ‘…)’ after the 50th digit.
Sample Input
76 25
5 43
1 397

Sample Output

76/25 = 3.04(0)
   1 = number of digits in repeating cycle

5/43 = 0.(116279069767441860465)
   21 = number of digits in repeating cycle

1/397 = 0.(00251889168765743073047858942065491183879093198992...)
   99 = number of digits in repeating cycle

中文:

给你一个分数的分子和分母,让你计算这个分数的循环节,把循环出现的部分用括号括起来,如果循环节长度超过50,那么就输出前50位,然后输出…。最后输出循环节长度和一段固定的文字

代码:

#include<bits/stdc++.h>
using namespace std;
int fra,den;
unordered_map<int,int> umi;
vector<int> v;
int main ()
{
    ios::sync_with_stdio(false);
    while(cin>>fra>>den)
    {
        v.clear();
        int head=fra/den;
        int tmp=fra%den;
        cout<<fra<<'/'<<den<<" = "<<head<<'.';
        umi.clear();
        int flag=0,st,res;
        tmp*=10;
        umi[tmp]=0;

        while(true)
        {
            if(fra%den==0)
                break;

            while(tmp<den)
            {
                tmp*=10;
                v.push_back(0);
                if(umi.find(tmp)!=umi.end())
                {
                    st=umi[tmp];
                    flag=1;
                    break;
                }
                umi[tmp]=v.size();
            }
            if(flag)
                break;
            if(tmp%den==0)
            {
                v.push_back(tmp/den);
                break;
            }
            res=(tmp%den)*10;

            v.push_back(tmp/den);
            if(umi.find(res)!=umi.end())
            {
                flag=1;
                st=umi[res];
                break;
            }
            umi[res]=v.size();
            tmp=res;
        }
        if(!flag)
        {
            for(auto x:v)
                cout<<x;
                cout<<"(0)"<<endl;
        }
        else
        {

            for(int i=0;i<st;i++)
                cout<<v[i];
            cout<<'(';
            if(v.size()-st<=50)
            {
                for(int i=st;i<v.size();i++)
                    cout<<v[i];
                cout<<')'<<endl;
            }
            else
            {
                for(int i=st;i<50;i++)
                    cout<<v[i];
                cout<<"...)"<<endl;
            }
        }
        if(flag)
            cout<<"   "<<v.size()-st<<" = number of digits in repeating cycle"<<endl;
        else
            cout<<"   "<<1<<" = number of digits in repeating cycle"<<endl;
        cout<<endl;
    }
    return 0;
}














解答:

在纸上计算一下可以发现规律,模拟手动计算除法的过程,每次余数补零的数记录到map当中,并记录当前补零时数字计算到了多少位,如果下一次计算的数再次补零后在map当中出现过,那么说明开始出现循环,将当前map当中记录的位置作为循环开始项即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值