uva10881解题报告

Problem D
Piotr's Ants
Time Limit: 2 seconds

"One thing is for certain: there is no stopping them;
the ants will soon be here. And I, for one, welcome our
new insect overlords."
Kent Brockman

Piotr likes playing with ants. He has n of them on a horizontalpole L cm long. Each ant is facing either left or right and walksat a constant speed of 1 cm/s. When two ants bump into each other, theyboth turn around (instantaneously) and start walking in opposite directions.Piotr knows where each of the ants starts and which direction it is facingand wants to calculate where the ants will end up T seconds from now.

Input
The first line of input gives the number of cases, N. Ntest cases follow. Each one starts with a line containing 3 integers:L , T and n (0 <= n <= 10000) .The next n lines give the locations of the n ants (measuredin cm from the left end of the pole) and the direction they are facing(L or R).

Output
For each test case, output one line containing "Case #x:"followed by n lines describing the locations and directions of then ants in the same format and order as in the input. If two or moreants are at the same location, print "Turning" instead of "L" or "R" fortheir direction. If an ant falls off the pole before T seconds,print "Fell off" for that ant. Print an empty line after each test case.

Sample InputSample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R


Problemsetter: Igor Naverniouk
Alternate solutions: Frank Pok Man Chu and Yury Kholondyrev

 

 

把蚂蚁的碰撞看成“对穿”,时间t后的所有蚂蚁位置即可确定,蚂蚁的相对顺序不变,就可以找到每个位置所对应的蚂蚁。
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int N;
struct ant{
    int pos;
    int dir;
    int id;
    bool operator<(const ant&t)const{
        return pos<t.pos;
    }
}before[10010],after[10010];
int ps[10010];
const char* str[]={"L","R","Turning","Fell off"};
int main(){
    int i,j,k,m,n,l,t;
    int kase;
    char c;
    scanf("%d",&N);
    for(kase=1;kase<=N;kase++){
            printf("Case #%d:\n",kase);
        scanf("%d%d%d",&l,&t,&n);
        for(i=0;i<n;i++){
            scanf("%d %c",&j,&c);
            if(c=='R'){
                after[i]=(ant){j+t,1,i};
            }
            else {
                after[i]=(ant){j-t,0,i};
            }
            before[i]=(ant){j,0,i};
            
        }
        sort(before,before+n);
        sort(after,after+n);
      //  if(after[0].pos<0||after[0].pos>l)after[0].dir=3;
        for(i=1;i<n;i++){
            if(after[i].pos==after[i-1].pos){
                after[i].dir=after[i-1].dir=2;
            }
//            if(after[i].pos<0||after[i].pos>l)after[i].dir=3;
        }
        for(i=0;i<n;i++){
            ps[before[i].id]=i;
        }
        for(i=0;i<n;i++){
            if(after[ps[i]].pos<0||after[ps[i]].pos>l)printf("%s\n",str[3]);
            else
            printf("%d %s\n",after[ps[i]].pos,str[after[ps[i]].dir]);
        }
        printf("\n");
    }
    return 0;
}
            

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值