hdu2844 Coins

Coins

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 44   Accepted Submission(s) : 24
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8

4

给出硬币数量和价值 求能凑出的数字的种类数 和那道dividing题目相似,只不过这里是最后需要遍历dp[1]-dp[m]中能凑到的i的数量。

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int main(){
    int kind,money;
    while(scanf("%d%d",&kind,&money))
    {   
        if(kind==0&&money==0)break;
        int v[111];
        int s[111];
        int dp[111111];
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        int i,j,k;
        for(i=1;i<=kind;i++)
        cin>>v[i];
        for(i=1;i<=kind;i++)
        cin>>s[i];
        for(i=1;i<=kind;i++)
        {
            for(j=1;j<=s[i];j*=2)
            {
                for(k=money;k>=j*v[i];k--)
                {
                    if(dp[k-j*v[i]])
                  dp[k]=1;
                }
                s[i]-=j;
            }
                if(s[i]>0)
                {
                    for(k=money;k>=s[i]*v[i];k--)
                    if(dp[k-s[i]*v[i]])
                    dp[k]=1;
                }
             
        }
        int js=0;;
         for(int ss=1;ss<=money;ss++)
         if(dp[ss])
          js++;
        cout<<js<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值