hdu 1969 Pie

12 篇文章 0 订阅
7 篇文章 0 订阅

Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12502    Accepted Submission(s): 4424


Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 

Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
  
  
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output
  
  
25.1327 3.1416 50.2655

 


因为不能拼接,所以最极端情况就是每个人都能分到最大面积饼的大小,当然这几乎不可能,所以就要用二分,从0到最大面积之间二分查找,一直找到一个最大的面积,每个人都能从给的饼里面拿到这个面积的饼,并且是完整的。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<iomanip>
#include<algorithm>
using namespace std;
double pi = acos(-1.0);
double a[10005];
int n,m;
int check(double mid)
{
    int i;
    int sum = 0;
    for(i = 0; i<n; i++)
    {
        int ss=a[i]/mid;
        sum+=ss;
        if(sum>=m)
            return 1;
    }
    return 0;
}

int cmp1(double a,double b)
{
    return a>b;
}

int main()
{
    int t,i,j;
    double l,r,mid;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        m++;
        for(i = 0; i<n; i++)
        {
            cin>>a[i];
            a[i] = a[i]*a[i]*pi;
        }
        sort(a,a+n,cmp1);
        l = 0;
        r = a[0];
        if(m<n)
            n = m;
        while(r-l>0.0000001)
        {
            mid = (r+l)/2;
            if(check(mid))
                l = mid;
            else
                r = mid;
        }
        cout<<setprecision(4)<<fixed<<l<<endl;
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值