比赛 C - Optimal Parking

Description

When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs.
Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round?
Long Street is a straight line, where all positions are integer.
You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.
 

Input

The first line of input gives the number of test cases, 1 <= t <= 100. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1 <= n <= 20, and the second gives their n integer positions on Long Street, 0 <= xi <= 99.
 

Output

Output for each test case a line with the minimal distance Michael must walk given optimal parking.
 

Sample Input

    
    
2 4 24 13 89 37 6 7 30 41 14 39 42
 

Sample Output

    
    
152 70
 

简单的水题。需要良好的数学思维,主要思想就是如果一个一个的走的话,每个地点都要走来回两遍,所以,可以看做是一个数轴:

                0 ——13 —— 24 —— 37 ——— 89———如果这样的话,可以转换成从最小值走到最大值,这样相当于只走了红色线部分:
#include <iostream>
using namespace std;
int main()
{
    int n,m;
    int a[105];
    cin>>n;
    while(n--)
    {
        cin>>m;
        for(int i=1;i<=m;i++)
        {
            cin>>a[i];
        }
        int min=1000;
        int max=0;
        for(int i=1;i<=m;i++)
        {
            if(min>a[i])
                min=a[i];
            if(max<a[i])
                max=a[i];
        }
        cout<<(max-min)*2<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值